1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

No posts show after vb3.8x import

Discussion in 'Installation, Upgrade, and Import Support' started by Phil Conway, Jan 2, 2011.

  1. Phil Conway

    Phil Conway Active Member

    I've just imported from an existing vb 3.8x forum.

    After the import, all threads, users and attachments seem to have been pulled across, but I've noticed two problems:

    1) When you click on any thread, no posts are displayed, even when there are posts present in the thread. (see below pic).

    2) Clicking on any thread link from the front page generates an error stating "The requested post could not be found." The link for each thread appears as http://www.nucastle.co.uk/index.php?posts/0/

    I've tried rebuilding my indexes without success. There are no errors in the xF server error log.

    Any ideas or guidance would be appreciated :)
     

    Attached Files:

  2. Mikey

    Mikey Well-Known Member

    Do you have a back up of 3.8.x db?

    Did you run maintenance tools on 3.8.x before import, such as rebuild post cache, remove all plugins etc?

    You may just have to do the import again. If you can't face that I suggest hiring someone to do it :)
     
  3. Phil Conway

    Phil Conway Active Member

    Yeah, carried out a full backup of everything before I went ahead and removed plugins where possible.

    Will retry and see how it goes :)
     
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    I assume everything works when you create a new thread?

    That makes me think you need to run these:

    Admin CP -> Tools -> Rebuild Caches
    > Rebuild Thread Information
    > Rebuild Forum Information


    If that doesn't work then there might actually be 0 posts in that forum. Make sure the posts exist in the vB database.
     
  5. Phil Conway

    Phil Conway Active Member

    I tried running those with no success before I posted. Poked around in the vb database and the posts are definitely there. Posting new threads works without any problems.

    I'm currently trying again with a fresh copy of xF, hopefully this will work.
     
  6. Phil Conway

    Phil Conway Active Member

    Tried again, I get exactly the same results. Rebuilding the thread/forum cache has no effect.
     
  7. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    I would like to examine the two databases if you are willing to give me access to your server. Or I can try running the import myself if you give me a copy of your database.
     
    zappaDPJ likes this.
  8. Phil Conway

    Phil Conway Active Member

    Cheers for the kind offer but I'll give it another go. I managed to get this all working the first time I trialled xF without any problems (http://test.nucastle.co.uk), so I'm hoping that it's something minor that can be fixed.
     
  9. Phil Conway

    Phil Conway Active Member

    Sorted. Cloned the database and ran the xF conversion on the cloned copy. I suspect there was a vB cron job running which was affecting the import.

    Posts now imported, sorting the attachments now and then it should be complete :)
     
  10. Phil Conway

    Phil Conway Active Member

    Dean likes this.
  11. Dean

    Dean Well-Known Member

    You don't mess around, nice (large) site. :)
     

Share This Page