1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 No permission

Discussion in 'Styling and Customization Questions' started by Bdarkslayer, Jan 2, 2015.

  1. Bdarkslayer

    Bdarkslayer New Member

    Hello XF,

    I am having an issue uploading a theme to my website. I have followed the instructions on various videos and I have gotten to the same spot each time. Once I click import, I get a page that says I don't have permission to upload themes. I have checked my permissions but nothing looked like it.

    Does anyone have any ideas as to what is going on?

    Thanks,
    - Bdark
     
  2. Jim Boy

    Jim Boy Well-Known Member

    From a XF point of view, make sure you are a superadmin - your config.php should include a line with your userid like
    $config['superAdmins'] = '17,234';
     
  3. Bdarkslayer

    Bdarkslayer New Member

    I must have not downloaded that file. Is there any way that I can get to it?
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    The config.php file is required in order to load the site - without it your site won't work at all.

    It is generated during installation (in most cases).

    It is located in the /library directory.

    Alternatively, a Super Administrator can assign the permission to your account to manage styles.

    upload_2015-1-2_11-31-26.png
     
  5. Bdarkslayer

    Bdarkslayer New Member

    Hey @Brogan,

    I have went to my permission panel for each user and I don't seem to have the style node. I am in the area where is has a gray, red and green area. If I am not in the right spot, can you direct me to it?
     
    Last edited: Jan 2, 2015
  6. Bdarkslayer

    Bdarkslayer New Member

  7. Brogan

    Brogan XenForo Moderator Staff Member

    That's a different issue and could be related to mod_security.

    Contact your host and they should be able to resolve it.
     

Share This Page