1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

No links in signatures except for forum sponsors?

Discussion in 'Forum Management' started by PumpinIron, Dec 7, 2015.

  1. PumpinIron

    PumpinIron Member

    Is there an easy way to set it up so that only certain users can have links in their signatures?

    The reason for this is because I don't want anyone other than myself (the admin) and forum sponsors to be able to have working links in their signatures.

    Not sure if this is a good idea or a bad idea, but it seems like a good one.
  2. wang

    wang Well-Known Member

    It seems like a good idea in my opinion too. Xenforo makes that possible by setting the Allow links permisison to No. You can configure that per group.
  3. PumpinIron

    PumpinIron Member

    The thing is, when I set registered users group permissions to look like so (see attached) it still shows working links in their signatures on the forum.

    Shouldn't it make it so the links in their signature no longer work?

    Screen Shot 2015-12-07 at 2.00.43 PM.png
  4. Martok

    Martok Well-Known Member

    The permission changes aren't retrospective, if users already have links in signatures they will remain.

    You can user the Batch Update Users in the ACP to remove all signatures, then get users to add their signatures again. Those without permission then won't be able to add links.
    PumpinIron likes this.
  5. PumpinIron

    PumpinIron Member

    That explains it! Thanks for answering that. Fortunately there's only a few users with links so I can easily go through and do it manually.
  6. PumpinIron

    PumpinIron Member

    CRAP... I changed it so Registered users can't have links or images in their signature, then went to the administrative group and made it so they CAN have links or images in their signatures. However, the settings from the Registered user group seems to be overriding the Administrative user group settings.
  7. Martok

    Martok Well-Known Member

    You've probably used the Never permission setting. Don't use Never, it cannot be overridden. Use Not Set (No) instead.
  8. PumpinIron

    PumpinIron Member

    Stupid me... It's because I didn't set myself (the admin) as part of the Administrative Group. Duh....

Share This Page