1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Nginx rules and registration errors

Discussion in 'Server Configuration and Hosting' started by mrmad, Jul 10, 2013.

  1. mrmad

    mrmad Member

    Hi there,
    I have a vps server running with nginx php5-fpm and apc running pretty fine until a couple of days until I tried to update to php5.5 which didn't come out the way I expected and so I decided to downgrade. Oddly enogh a php info file says it is PHP Version 5.4.17RC1 , php -v command in terminal says:
    Code:
    PHP 5.3.24 (cli) (built: Jul  5 2013 23:31:37)
    
    The vps is used for wordpress and xenforo with wordpress installed here /var/www/website/ and xenforo
    in /var/www/website/forum.

    I have one nginx.conf file for wordpress and xenforo. The xenforo configuration which used to work until a couple of days without any problems:

    PHP:
    ###xenforo
    location /forum/ {
        
    try_files $uri $uri/ /forum/index.php?$uri&$args;
        
    index index.php index.html;
    }

    location /forum/internal_data/ {
        
    internal;
    }
    location /forum/library/ {
          
    internal;
    }
    }
    }
    Pretty URLs are enabled and working. The problem now is that no user can register : server error is show as the are redirected to the following page http://www.domain.tld/forum/login/login nor can users be created manually in the admin backend. Simply nothing happens when the settings are saved.
    The error log doesn't show anything and this problem happens no matter which plugins are enabled or disabled.
    I would be grateful for any help since a forum where registration does not work is pretty useless.
     
  2. AlexT

    AlexT Well-Known Member

    Is it possible that you have different versions installed for 1) the CLI version of PHP and 2) the FPM version? Check the binaries, e.g.

    /usr/bin/php5 -v
    /usr/bin/php5-cgi -v
    /usr/sbin/php5-fpm -v

    You can get very detailed log information to pinpoint the error by adding the following snippet to your nginx.conf file:

    Code:
    events {
        ...
        debug_connection <your ip>;
        ...
    }
    Make sure to reload your nginx configuration, then check the error file for details as you visit your site and force the error.[/quote]
     
  3. mrmad

    mrmad Member

    hmm, the nginx error log doesn't show any error for today but I think you nailed down the problem:
    Code:
    /usr/bin/php5 -v
    PHP 5.4.17RC1 
    Code:
    /usr/bin/php5-cgi -v
    PHP 5.4.17RC1 (cgi-fcgi) 
    Code:
    /usr/sbin/php5-fpm -v
    [10-Jul-2013 17:35:34] NOTICE: PHP message: PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/fpm/conf.d/20-apc.ini on line 1 in Unknown on line 0
    [10-Jul-2013 17:35:34] NOTICE: PHP message: PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/fpm/conf.d/20-apc.ini on line 2 in Unknown on line 0
    [10-Jul-2013 17:35:34] NOTICE: PHP message: PHP Warning:  Module 'apc' already loaded in Unknown on line 0
    [10-Jul-2013 17:35:34] NOTICE: PHP message: PHP Warning:  Module 'PDO' already loaded in Unknown on line 0
    PHP 5.4.17RC1 (fpm-fcgi) (built: Jun 22 2013 08:46:31)
    Copyright (c) 1997-2013 The PHP Group
    Zend Engine v2.4.0, Copyright (c) 1998-2013 Zend Technologies
    Any idea?
     
  4. dbembibre

    dbembibre Active Member

  5. mrmad

    mrmad Member

    Hi, I do not use a panel at all.
    I believe the problem was APC. Now with Xcache and Memcached I don't have any problems, however it is a real pity about apc because the server used to be much snappier and faster (especially wordpress) with APC.
     

Share This Page