1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

nginx - phpmyadmin and ssl

Discussion in 'Server Configuration and Hosting' started by speedway, Apr 11, 2013.

  1. speedway

    speedway Well-Known Member

    OK, next problem

    Updated nginx to 1.2.8 along with php to 5.3.23, all via the latest centminmod script. Along the way the script updated openssh on my Centos system (a Servint VPS). Problem is that now ssl and phpmyadmin do not work.

    Have tried regenerating the ssh keys and cert etc but still no go. Does anyone have a conf file that works with phpmyadmin and nginx under ssl? I would just like to compare what I have with someone elses.

  2. Tracy Perry

    Tracy Perry Well-Known Member

    My pertinent section for SSL out of mine on debian
    server {
    server_name twowheeldemon.com;
    listen 443;
    ssl on;
    ssl_certificate /etc/nginx/conf/server.crt;
    ssl_certificate_key /etc/nginx/conf/server.key;
    location /****sandgrins {
    auth_basic "Restricted";
                    auth_basic_user_file /etc/peewords/pass.word;
                  root /usr/share/;
                  index index.php index.html index.htm;
                  location ~ ^/justforgiggles/(.+\.php)$ {
                          try_files $uri =404;
                          root /usr/share/;
                          fastcgi_index index.php;
                          fastcgi_param SCRIPT_FILENAME
                          include /etc/nginx/fastcgi_params;
                  location ~*
                          root /usr/share/;
            location /****sandgrins {
                  rewrite ^/* /****sandgrins last;
    hehehehe... my directory name for my phpmyadmin got censored. :rolleyes:
  3. I am David

    I am David Member

    How can you apply SSL across all domains?

    # HTTPS server
    server {
        listen      443 ssl;
        server_name  localhost;
        ssl                  on;
        ssl_certificate      /etc/nginx/server.crt;
        ssl_certificate_key  /etc/nginx/server.key;
        ssl_session_timeout  5m;
        ssl_protocols  SSLv2 SSLv3 TLSv1;
        ssl_ciphers  HIGH:!aNULL:!MD5;
        ssl_prefer_server_ciphers  on;
    #    location / {
    #        root  usr/share/nginx/html;
    #        index  index.html index.htm;
    #    }
    I was trying something like that above. Does it not work this way? Do I need to make SSL config edits for each domain affected? Thanks for any input... There is more NGINX support here than any other website... xenforo should just make their own NGINX area. (More traffic More sales? :p )
  4. Tracy Perry

    Tracy Perry Well-Known Member

    Would not changing to list all your domains work, or are you wanting it on everything? I don't mess much with SSL (since the key file I use is a private made on the box itself) but aren't the official ones tied to the individual domain for each public key file?
  5. I am David

    I am David Member

    i listed all of my domains but nothing is catching...

    I see 443 listening... but still only catching on one site. Thanks for the mind reboot, I will keep trying with different configs.

    tcp        0      0      *                  LIST  
  6. Tracy Perry

    Tracy Perry Well-Known Member

    Port 443 open? By default my iptables rule I set up had specifically closed it since I wasn't using it. I had to remember to go back in and open it back up.

Share This Page