• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Nginx failed to build

Fred.

Well-known member
#1
Hi,

I just ran into a problem while i was rebuilding Nginx.
I tried a new configuration file, then I got this. So I put my old configuration file back but I still get this.

Spdy is in there.
Can anyone help me with this?
It's a server with directadmin. It's completely down now. :eek: :cry: :coffee:

Code:
Enabling nginx in systemd...
Using 109.**.161.92 for your server IP
Using 109.**.161.92 for your server IP
Checking to ensure /etc/nginx/ssl.crt/server.ca is set.
Using 109.**.161.92 for your server IP
Using 109.**.161.92 for your server IP
Restarting nginx.
Job for nginx.service failed. See 'systemctl status nginx.service' and 'journalctl -xn' for details.
[root@server01 custombuild]# systemctl status nginx.service
nginx.service - The nginx HTTP and reverse proxy server
   Loaded: loaded (/etc/systemd/system/nginx.service; enabled)
   Active: failed (Result: exit-code) since zo 2015-04-12 23:53:17 CEST; 25s ago
  Process: 70454 ExecStartPre=/usr/sbin/nginx -t -c /etc/nginx/nginx.conf (code=exited, status=1/FAILURE)
Main PID: 11823 (code=exited, status=0/SUCCESS)

apr 12 23:53:17 server01.example.com systemd[1]: Starting The nginx HTTP and reverse proxy server...
apr 12 23:53:17 server01.example.com nginx[70454]: nginx: [emerg] the "spdy" parameter requires ngx_http_spdy_module in /etc/nginx/nginx-vhosts.conf:27
apr 12 23:53:17 server01.example.com nginx[70454]: nginx: configuration file /etc/nginx/nginx.conf test failed
apr 12 23:53:17 server01.example.com systemd[1]: nginx.service: control process exited, code=exited status=1
apr 12 23:53:17 server01.example.com systemd[1]: Failed to start The nginx HTTP and reverse proxy server.
apr 12 23:53:17 server01.example.com systemd[1]: Unit nginx.service entered failed state.
 

Fred.

Well-known member
#3
Looks to me like the spdy module wasn't included in compile time... Are you sure you had it included?

Liam
It's in configure.nginx
Then it should be ok right?

Code:
#!/bin/sh
./configure \
    "--user=nginx" \
    "--group=nginx" \
    "--prefix=/usr" \
    "--sbin-path=/usr/sbin" \
    "--conf-path=/etc/nginx/nginx.conf" \
    "--pid-path=/var/run/nginx.pid" \
    "--http-log-path=/var/log/nginx/access_log" \
    "--error-log-path=/var/log/nginx/error_log" \
    "--with-ipv6" \
    "--without-mail_imap_module" \
    "--without-mail_smtp_module" \
    "--with-http_ssl_module" \
    "--with-http_realip_module" \
    "--with-http_stub_status_module" \
    "--with-http_gzip_static_module" \
    "--with-http_dav_module" \
    "--with-cc-opt='-D FD_SETSIZE=32768'" \
    "--with-http_spdy_module"
Or what can I do to check that?
 

Tracy Perry

Well-known member
#4
nginx -V should give you something like this
nginx version: nginx/1.7.6

built by gcc 4.4.7 20120313 (Red Hat 4.4.7-4) (GCC)

TLS SNI support enabled

configure arguments: --with-cc-opt='-I/svr-setup/staticlibssl/include -I/usr/include' --with-ld-opt='-L/svr-setup/staticlibssl/lib -Wl,-rpath -lssl -lcrypto -ldl -lz' --sbin-path=/usr/local/sbin/nginx --conf-path=/usr/local/nginx/conf/nginx.conf --with-http_ssl_module --with-http_gzip_static_module --with-http_stub_status_module --with-http_sub_module --with-http_addition_module --with-http_image_filter_module --with-http_secure_link_module --with-http_flv_module --with-http_realip_module --with-openssl-opt=enable-tlsext --add-module=../ngx-fancyindex-ngx-fancyindex --add-module=../ngx_cache_purge-2.1 --add-module=../headers-more-nginx-module-0.25 --add-module=../nginx-accesskey-2.0.3 --add-module=../nginx-http-concat-master --with-http_dav_module --add-module=../nginx-dav-ext-module-0.0.3 --with-openssl=../openssl-1.0.1j --with-libatomic --with-pcre=../pcre-8.35 --with-pcre-jit --with-http_spdy_module --add-module=../ngx_pagespeed-release-1.9.32.1-beta
So check and make sure it is compiled in.

What OS are you compiling on?