• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Nginx 1.4 and SPDY

Mouth

Well-known member
#1
I've upgraded to to nginx 1.4, and added spdy to my listen parameter. It works when I access the sites via https, but if I access via http then I get an 'internal error' Remove spdy on the :80 listen parameter and it works fine again.
 

Andy.N

Well-known member
#2
I used it. SPDY requires HTTPS. What you see is expected.
Why don't you redirect all http connections to https?
 

Jeremy P

Well-known member
#5
As above, SPDY requires HTTPS. You will want to redirect all http traffic to https.

You should serve all css, javascript, and images over https too, to avoid problems like you described.
 
Top