• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 newbie/ newcomer trying to import infrastructure only to new/ fresh installation

#1
hi all, i am completely and utterly new to all this and am a starter and beginner.

OLD INSTALL was on 1.5.11 -> NEW INSTALL is on 1.5.12

1) i had a XenForo Installation, where i created FORUMS and CATEGORIES, but nothing else. (nothing else, was just created NODES [infrastructure)
2) then due to hosting being very slow, i moved from 1&1 Germany to i3D.net
3) on i3D.net i installed completely from scratch, fresh installation and new, and it works
4) now i want to import the FORUMS and CATEGORIES that i created on the 1&1 installation into the new/ fresh installation on i3D.net
5) i tried with the IMPORTER, but don't get anywhere and don't know what else to do.

*** only installed RESOURCE MANAGER (was identical on old installation)
*** only installed DISABLE RSS (ANDY) (was identical on old installation)

any help is greatly appreciated and sorry if all my questions are stupid or easy for some, i just don't get it.

what am i doing wrong? or how to do it correctly?

thanks again everyone.

attached screenshots.
1.png 2.png 3.png
 
Last edited:
#2
hi all, I attempted importing the SQL file via phpMyAdmin but i get this error message:
1.png
what do i need to do to correct it and have it import correctly?
 

Mike

XenForo developer
Staff member
#3
Since you're dealing with the database level, you can't have a new installation and the importer is not directly relevant.

You need to empty the new database (as in remove all tables or just delete and recreate it) and then try to import your database backup into it. Your errors are because it's not empty. Ideally, you should move your old files to the new host as well. Once you do all that, you'll need to update library/config.php to the MySQL details for your new host. If this is all done, your existing install should be migrated and you can go from there.

(See #6 in this post: https://xenforo.com/community/threads/frequently-asked-questions.5183/#post-180455)
 

Jake Bunce

XenForo moderator
Staff member
#4
I understand you want to copy your node structure between two different XenForo installations. Here are some options:

1) Don't use a second installation. Instead just copy the existing installation by doing a backup / restore cross servers.

https://xenforo.com/community/resources/how-to-backup-and-restore-your-forum-linux-windows.359/

2) Do an import from XenForo to XenForo.

https://xenforo.com/help/importing/
https://xenforo.com/community/threads/import-guide.10053/

This still requires you to backup + restore the database on the new server so you can import from it on the new server.

3) Manually restore individual node related tables from the original database to the new database. This requires SQL ability and may be problematic with respect to relations in your database. Not recommended.

4) Manually recreate your node structure using the Admin CP and the old forum for reference.
 
#5
thank you guys. just curious to clarify:
1) if i upload the original installation to the new "host/ server"
2) do i still need to create a new database on the new "host/ server"
3) how does the uploaded "copy" of the forum on he new "host/ server" create all the tables and all he stuff that it needs in the new database?
4) or do i just create a blank database, enter all the new login data to --> library/config.php and XenForo does the rest?
 
#6
5) when i upload the "FORUM" to the new host/ server, how do i make sure and know the "PERMISSIONS" for the folders are set correctly? is that something to look into and make sure is correct?
 
#7
when i import, I get this error now phpMyAdmin:

Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 56482755 bytes) in /var/www/html/phpMyAdmin-3.5.8.2-all-languages/libraries/import.lib.php on line 290
 

Mike

XenForo developer
Staff member
#8
phpMyAdmin is not the best method of importing (or exporting) the database as you're up against various restrictions. If you're having errors importing your data, your host would likely be the one who'd need to help there as they would have access to command line tools without the restrictions. Getting the data imported to the new server is a precursor to any automated action; if you can't do that, you'd really need to recreate the node structure using a fresh installation.

3) how does the uploaded "copy" of the forum on he new "host/ server" create all the tables and all he stuff that it needs in the new database?
4) or do i just create a blank database, enter all the new login data to --> library/config.php and XenForo does the rest?
When you import the data from the database (via phpMyAdmin or other command line tools), it creates everything that was in the database before. You then just need to point XenForo at it via the config.php file.

5) when i upload the "FORUM" to the new host/ server, how do i make sure and know the "PERMISSIONS" for the folders are set correctly? is that something to look into and make sure is correct?
The only thing to do is to check the permissions on the data and internal_data directories. If you're not sure if they're correct, you can try uploading an image attachment; if it uploads correctly and creates a thumbnail, you should be fine.
 
#9
GOT IT ALL TO WORK. good to mention PERMISSIONS for each and every folder have to be set, once i did that, identical to old server. all was smooth sailing.