• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 New To Xenforo - Trying To Understand Permissions

#1
Hi guys, as the titles says, Im new and you have probably heard this a thousand times before. I assume its a permissions issue. but i cant seem to bottom it out. Ive just imported from SMF.

My forum says - "You have insufficient privileges to reply here"

I assume all users are in registered usergroup.
registered usergroup seems to have all permissions set correct.

Next I checked the node Permissions for the node
Registered Usergroup has all the correct permissions to reply

However, when I check individual members prmissions, they have no permission to reply ?? How come the registered users group permissions arent being applied to each user ??

My forum is at this url :

Sea Fishing Forum - Shore, Boat & Kayak Fishing | Whitby Sea Anglers Forums
 

Martok

Well-known member
#3
As well as the guide that @Zynephix has linked you to, you will also find this guide useful:

Understanding Permissions


If you're still having problems, use the Analyse Permissions feature in the ACP to check permissions for individual users and for nodes (if you haven't already done this). You can post screenshots of what you see in this if you still can't get it to work.
 
#4
Ive read that and I think Ive grassped the concept. But how come that Registered members have post and reply permissions, and the node is set to post and reply, but yet noone can reply ??
 
#5
It looks to me like the individual users are not taking on the usergroup permissions. Is there a way to make sure all users take on those permissions. Maybe this is linked to the important of my usergroups from SMF which I have now deleted ??
 

Martok

Well-known member
#6
But how come that Registered members have post and reply permissions, and the node is set to post and reply
If the Registered group has post and reply permissions, there should be no need to set them again for that group in node permissions, it can be left set to inherit.

We'll need more details to help further. So it would be useful if you can post screenshots of ACP > Users > Analyse permissions for a user showing 1) their Global permissions for post and reply and 2) Their Node permissions for post and reply.
 
#7
Right. I changed the node permissions to allow instead of inherit, and now we can post. So I assume the inherited permission were set to no. So the question is which group permissions were set to no ??
 

Martok

Well-known member
#8
Did you not read my last post?

If the Registered group has post and reply permissions, there should be no need to set them again for that group in node permissions, it can be left set to inherit.
Also
We'll need more details to help further. So it would be useful if you can post screenshots of ACP > Users > Analyse permissions for a user showing 1) their Global permissions for post and reply and 2) Their Node permissions for post and reply.