• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
New Posts

New Posts 2.1

No permission to download
Displays New Posts in the sidebar.

AndyB

Well-known member
#1
AndyB submitted a new resource:

New Posts - Displays new posts in the sidebar.

Description:

Displays new posts in the sidebar.

This add-on displays new posts to logged in members only. If you would like to show recent posts to your visitors, please download the the Recent Posts v1.0 add-on.

(Example of Recent Posts)

View attachment 86185

(Example of Options page)

View attachment 86186

Features:
  • All phrases start with newposts_ for your convenience.
Installation:
  1. Download newposts_v1.0.zip and unzip...
Read more about this resource...
 

zagorskey

Active member
#2
Great plugin, Andy. One little bug only: the anchor tag is improperly closed which causes all anchors not to be clickable.

This:
Code:
<a href="{xen:link 'threads/unread',  $thread}" title="{xen:helper snippet, $thread.message, 200}" />{$thread.title}</a>
should become this:
Code:
<a href="{xen:link 'threads/unread',  $thread}" title="{xen:helper snippet, $thread.message, 200}">{$thread.title}</a>
I also used a list (<ul>) which should be a better aproach than a table.
 

CFodder

Well-known member
#7
Hi Andy

Just a wee error with your notes, it should say to navigate to New Posts not Recent posts (guess this was from your other addon??) :).

Secondly I only have the Visitor Panel, who's online and forum stats in the sidebar but haven't been able to figure how to get these to display below the forum stats. I've tried changing the execution order but that hasn't helped, are you able to help please?

Thanks and as ever a great little addon.
 

AndyB

Well-known member
#9
I only have the Visitor Panel, who's online and forum stats in the sidebar but haven't been able to figure how to get these to display below the forum stats.
Hi CFodder,

In order to display the New Posts below the Forum Statistics, edit the Template Modification and change the Find to:

<!-- end block: forum_stats -->

pic001.jpg
 

CFodder

Well-known member
#12
Hi Andy

Am coming across an error where the latest post drops off after it's been read. It will then reappear and stay in the widget when a newer post is made.

Am running XF 1.4.1 and do have a few addons installed. This is on my locked forum too, not the OLDr one.

**EDIT ** This is working as intended, my mistake for confusing it with latest posts.
 
Last edited:
#16
Not sure if I'm doing something wrong - but it doesn't appear to be showing on my forum correctly - despite being enabled?

Could this be as "Last Post" is still installed - but disabled?