1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed New member registration in 1.2.1

Discussion in 'Resolved Bug Reports' started by dan_mail, Aug 21, 2013.

  1. dan_mail

    dan_mail New Member

    I have just been updated to 1.2.1
    After that during new member registration I get
    ErrorException: Fatal Error: syntax error, unexpected T_FUNCTION - library/XenForo/Mail.php:362
    #0 [internal function]: XenForo_Application::handleFatalError('XenForo_Mail')
    #1 {main}
  2. JulianD

    JulianD Well-Known Member

    Make sure you have uploaded all the files correctly. I don't have a test board at hand but syntax error bugs are very rare.
  3. xf_phantom

    xf_phantom Well-Known Member

    What phpversion are you using?
  4. dan_mail

    dan_mail New Member

    PHP 5.3
  5. dan_mail

    dan_mail New Member

    I have reuploaded previous version of Mail.php (from 1.2.0) and registration is OK now.
    But this is strange still.
  6. Moshe1010

    Moshe1010 Well-Known Member

    I cannot reproduce this on my test system with 1.2.1
  7. Mike

    Mike XenForo Developer Staff Member

    You must be using PHP 5.2, as it appears that a change broke that. I'll be posting an update in the announcements forum.
    dan_mail and xf_phantom like this.
  8. dan_mail

    dan_mail New Member

    Does someone know which changes have happened in 1.2.1-version of Mail.php in comparison to previous one?
    I worry about consequenses of my manipulation.
  9. BamaStangGuy

    BamaStangGuy Well-Known Member

Share This Page