XF 2.1 New Install - white page

AngelArs

Active member
Uploaded all files to the server (forum directory) and went to www.mysite.com/forum/install but all I see is a white page.

I am using https and not http, would that make a difference?

The last time I installed Xenforo fresh I remember filling out a config file. I didn't see one. Do I still need to do one?
 

NobleMan

Active member
seems like your connection to the DB is not happening, did you create a new DB and then input the info during install?
 

AngelArs

Active member
Yes I created a DB. I found the config file in the src folder. Added username, password and db name, then renamed config file to config.php and uploaded it. Refreshed page. Same issue, white page.
 

AngelArs

Active member
I'm making progress. Now it says "The requested URL was not found on this server." even though I know it's installed in the right directory.

I also made sure that the data and internal data folders were set to 777, but still white page.
 

djbaxter

Well-known member
Try adding this line to your config.php file - this may tell you more specifically what errors Xenforo is encountering:

Code:
// enable error reporting
ini_set('display_errors', true);
Then post any errors that are displayed here.

Once you have your forum working properly, remember to go back and either delete those lines or chnage them to read

Code:
// enable error reporting
ini_set('display_errors', false);
 

AngelArs

Active member
Do I just add it to the end of the config file like this?

$config['db']['socket'] = null;

// enable error reporting
ini_set('display_errors', true);

$config['fullUnicode'] = true;


Because it's not doing anything differently.
 

djbaxter

Well-known member
Odd.

Try using the full URL for the install package. Maybe your defaults is not set or is set to something other than index.php.

So use www.mysite.com/forum/install/install.php
 
Last edited:

djbaxter

Well-known member
1. Are you absolutely certain you uploaded the files to the correct directory on your server? Usually this will be public _html/ (or in your case public_html/forum/)but different server configurations may have different names for that folder.

2. What is in the root folder, i.e., what is currently in public_html or the equivalent? If you are using that for another platform, like WordPress for example, do you have any redirects that might be messing you up, either in .htaccess or in cPanel?
 

Deathstarr

Well-known member
The problem is you made the config file.

Delete the config.php file and then go to your mydomain.com/forum/install You will put your information in during the install.
 

AngelArs

Active member
Thank you everyone for trying to help. I contacted the host and they have found the problem.

Instead of mysite.com/forum/install

It should have been;

mysite.com/forum/install/index.php?install/
 

Deathstarr

Well-known member
While I am glad you got it resolved, it should have redirected you to the correct place if you went to mysite.com/forum/install.

Good luck on your forum.
 
Top