• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 New DNS / Errors on registration : Duplicate entry

kankan

Active member
#1
Hello
I just migrate my XF setup last night.
During DNS propagation, the XF cache did not run properly:
When creating new thread, the new message was displayed under existing an existing thread.
I fixed this by running cache rebuild and all went ok.
Despite, i am still facing an issue on registration.
After clicking to validate registration form, the page display an error.

In admin, system displays this message :

Erreur Info
Zend_Db_Statement_Mysqli_Exception: Mysqli statement execute error : Duplicate entry '20016' for key 1 - library/Zend/Db/Statement/Mysqli.php:214
Généré par: Compte incconu, il y a un instant
Trace de la pile
#0 /home/e-smith/files/ibays/forumasus/html/forums/library/Zend/Db/Statement.php(297): Zend_Db_Statement_Mysqli->_execute(Array)
#1 /home/e-smith/files/ibays/forumasus/html/forums/library/Zend/Db/Adapter/Abstract.php(479): Zend_Db_Statement->execute(Array)
#2 /home/e-smith/files/ibays/forumasus/html/forums/library/Zend/Db/Adapter/Abstract.php(574): Zend_Db_Adapter_Abstract->query('INSERT INTO `xf...', Array)
#3 /home/e-smith/files/ibays/forumasus/html/forums/library/XenForo/DataWriter.php(1624): Zend_Db_Adapter_Abstract->insert('xf_user_profile', Array)
#4 /home/e-smith/files/ibays/forumasus/html/forums/library/XenForo/DataWriter.php(1613): XenForo_DataWriter->_insert()
#5 /home/e-smith/files/ibays/forumasus/html/forums/library/XenForo/DataWriter.php(1405): XenForo_DataWriter->_save()
#6 /home/e-smith/files/ibays/forumasus/html/forums/library/MetaMirror/DataWriter/User.php(8): XenForo_DataWriter->save()
#7 /home/e-smith/files/ibays/forumasus/html/forums/library/XenForo/ControllerPublic/Register.php(416): MetaMirror_DataWriter_User->save()
#8 /home/e-smith/files/ibays/forumasus/html/forums/library/XenForo/FrontController.php(347): XenForo_ControllerPublic_Register->actionRegister()
#9 /home/e-smith/files/ibays/forumasus/html/forums/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#10 /home/e-smith/files/ibays/forumasus/html/forums/index.php(13): XenForo_FrontController->run()
#11 {main}
État de la demande
array(3) {
["url"] => string(63) "http://www.forum-des-portables-asus.fr/forums/register/register"
["_GET"] => array(0) {
}
["_POST"] => array(16) {
["username"] => string(0) ""
["e9a4a309564d44d3f59f32befefd850e"] => string(6) "nath92"
["a4c5a9120bb230971f66c0858e91a26f"] => string(29) "nathxxxxx_92@hotmail.com"
["password"] => string(8) "********"
["632ff374199808f4319d06f3b5129a7c"] => string(6) "female"
["dob_month"] => string(1) "3"
["dob_day"] => string(2) "23"
["dob_year"] => string(4) "1972"
["4c4b90a93cde6ed76e35417d729482d6"] => array(9) {
["asus"] => string(5) "rtyrt"
["achat"] => string(0) ""
["processeur"] => string(0) ""
["graphique"] => string(0) ""
["disque"] => string(0) ""
["memoire"] => string(0) ""
["ecran"] => string(0) ""
["systeme"] => string(6) "rtyrty"
["yxn1cw"] => string(0) ""
}
["custom_fields_shown"] => array(9) {
[0] => string(4) "asus"
[1] => string(5) "achat"
[2] => string(10) "processeur"
[3] => string(9) "graphique"
[4] => string(6) "disque"
[5] => string(7) "memoire"
[6] => string(5) "ecran"
[7] => string(7) "systeme"
[8] => string(6) "yxn1cw"
}
["9ab282feb608db7676374bed3c0c8b72"] => string(16) "Europe/Amsterdam"
["recaptcha_challenge_field"] => string(292) "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx_dO1ZqsnJyM_5qbkGEhvHCOPgvKfet3tBjyAEIpF24HAlYI9OwglTqRM-xwECB0Y_Z-9BG4KqQ6mnRepSYoHk-bJv3XLaHGLS_m2MUyTA6ErN1gIqeyfTLliPpx_-s0YyO9olR4RqQnqg6g7MfATWgBw7wITUmuyGijFOpHltRjxfgV3vbsgBTyy6VzkxIxQfLXDZZ8rjGxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx"
["recaptcha_response_field"] => string(4) "xxxx"
["agree"] => string(1) "1"
["_xfToken"] => string(8) "********"
["reg_key"] => string(32) "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx"
}
}
Latest physical entry in table xf_user is ID 20011.

Thanks
 
Last edited:

kankan

Active member
#2
Found the issue
Seems due to a bad sync.
Latest id in xf_user was 20021
Lastest id in xf_user_profile was 20026

i created 'ghost' users until reaching 20026
Next user 20027 was successfully created.

just did an import of missing users from older DB.

Question : is there another table impacted by this ?

Thanks for support.
 
Last edited: