• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.1 New Database

Xarcell

Well-known member
#1
I just changed hosts, and my database name has changed, as well as the password. How do I got about changing this in my backup of my site?

I backed-up the files and the DB and I already imported the sql file to the new database(after adjusting the DB name accordly).

What else should I be doing?

Thanks.
 

Xarcell

Well-known member
#3
I'm having issues. I'm opened my SQL file and changed the database name. I changed the information in the config file. It says there is a database error when I visit the site. However, I get a warning from my host saying I'm sending out over 300 emails an ahour from that site.

/home/xarcell/public_html/xarchology.com/library/XenForo/Mail.php:506: /**
/home/xarcell/public_html/xarchology.com/library/XenForo/Mail.php:507: * Get the default sendmail (built-in PHP mail()) transport object, based on the
/home/xarcell/public_html/xarchology.com/library/XenForo/Mail.php:508: * configuration in the given array.
Any ideas what I'm doing wrong?
 

Jake Bunce

XenForo moderator
Staff member
#4
View the source code of the database error page. It should give a more detailed error.

You can disable all emails by adding this to your library/config.php file:

Code:
$config['enableMail'] = 0;