1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Need help with SSL, weird error in XenForo.

Discussion in 'Troubleshooting and Problems' started by Yashjeet, Nov 4, 2014.

  1. Yashjeet

    Yashjeet Active Member

    I recently decided to use Universal SSL, I'm using the free version that's on CloudFlare.
    One issue, is that when I go onto my website (https://www.fa-mc.com) it is very weird looking, here's a picture:
    I cannot find a way to fix this, here is my .htaccess

    Any clues? I'm using CloudFlare for my domain, and CentOS for my VPS, and Apache for the webserver, and MySQL for the database.
  2. Yashjeet

    Yashjeet Active Member

  3. Martok

    Martok Well-Known Member

    47 minutes before you bump a topic?! Come on, be realistic, people do have lives you know. Plus it's outside of UK working hours too.
    Liam W, Amaury and Goodfella like this.
  4. Martok

    Martok Well-Known Member

    If you use your browser inspection tool on the page you linked to, it's not loading images as they are blocked due to running insecure content (over http).

    I suggest you take a look at Cloudflare's help section on SSL:


    There's at least one link on there related to Apache.

    Beyond that, I can't help as I don't use SSL or Cloudflare.
  5. Mike

    Mike XenForo Developer Staff Member

    Ideally, you need to use HTTPS between CloudFlare and your site as well. (For one, only SSL between the client and CloudFlare isn't really meeting the whole point of SSL.) Since CloudFlare is requesting your site without HTTPS, XenForo is reacting as such.
  6. Yashjeet

    Yashjeet Active Member

    Ah ok, but I just want my server members (they're at the ages of 8-16) and they wouldn't know what this is.
    I would just love https:// to be green, right now look at these:

    Is there any option in XenForo that'll not react to the HTTPS?
  7. nodle

    nodle Well-Known Member

  8. Yashjeet

    Yashjeet Active Member

    Okay, well you fixed all the problems, but now there's another problem.
    I added
    $_SERVER['HTTPS'] = 'on';
    to my .htaccess, and now my site is having this error:
    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, root@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Apache/2.2.15 (CentOS) Server at www.fa-mc.com Port 80

    Please note I'm running a dedicated server to host this website, and I need to fix whatever happens, not my host!
  9. nodle

    nodle Well-Known Member

    It needed to be added to your config file not your .htaccess file.
  10. Yashjeet

    Yashjeet Active Member

    Oh, where's the location of the "config" file?
  11. nodle

    nodle Well-Known Member

    Under Library>config.php, add it to the bottom line.
    Yashjeet likes this.
  12. Yashjeet

    Yashjeet Active Member

    Thanks so much man, that fixed the issue!
    Cheers, You're the best!
  13. Yashjeet

    Yashjeet Active Member

    Sorry for the bump, however I recently re-installed my VPS and now when I visit my site the https symbol is yellow.
    How do I fix this?
  14. Brogan

    Brogan XenForo Moderator Staff Member

  15. Yashjeet

    Yashjeet Active Member

    Oh thank you.
    I didn't know an image can cause that, haha!

Share This Page