• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 Need help immediately. Please Help!


Active member

I installed xenForo recently and i'm getting the following errors -

XenForo 1.2.4 - Errors
The following errors occurred while verifying that your server can run XenForo:

  • The required PHP extensions for XML handling (DOM and SimpleXML) could not be found. Please ask your host to install these extensions.
Please correct these errors and try again.

How do I fix this? I'm a VPS box. Also, I'm using CentOS 6 32bit Minimal

@Jake Bunce please help me :(
Last edited:


Active member
Try this:

yum install php-xml

yum install php5-xml
Hey, thanks for the reply.
When I run both of those commands, it gives me the following -
yum install php-xml5 gave me this -

[notTelling ~]# yum install php5-xml
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: ftp.osuosl.org
* epel: mirrors.cat.pdx.edu
* extras: ftp.osuosl.org
* updates: ftp.osuosl.org
Setting up Install Process
No package php5-xml available.

Error: Nothing to do

Both of them did it practically.


XenForo moderator
Staff member
As the error text states: "Please ask your host to install these extensions."

If you are not sure how to do it yourself, contact your host.


Active member