1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mysqli statement execute error : Incorrect string value: '\xDCRK-Ba...' for column 'message' at row

Discussion in 'Troubleshooting and Problems' started by Saburov, Jan 30, 2013.

  1. Saburov

    Saburov Active Member

    Mysqli statement execute error : Incorrect string value: '\xDCRK-Ba...' for column 'message' at row 1
    1. Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 317
    2. Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
    3. Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 574
    4. Zend_Db_Adapter_Abstract->insert() in XenForo/DataWriter.php at line 1591
    5. XenForo_DataWriter->_insert() in XenForo/DataWriter.php at line 1580
    6. XenForo_DataWriter->_save() in XenForo/DataWriter.php at line 1381
    7. XenForo_DataWriter->save() in XenForo/DataWriter/Discussion.php at line 407
    8. XenForo_DataWriter_Discussion->_saveFirstMessageDw() in XenForo/DataWriter/Discussion.php at line 355
    9. XenForo_DataWriter_Discussion->_postSave() in XenForo/DataWriter.php at line 1385
    10. XenForo_DataWriter->save() in XenForo/ControllerPublic/Forum.php at line 495
    11. XenForo_ControllerPublic_Forum->actionAddThread() in XenForo/FrontController.php at line 310
    12. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
    13. XenForo_FrontController->run() in /home/gezinen/public_html/index.php at line 13

    When I try to create a new post, sometimes i have this error message. What is this and how can i fix it? Thanks.
     
  2. Jon W

    Jon W Well-Known Member

    Hi,

    It's to do with non-standard characters.

    Please could you run the following MySql query and post the results here. This should help identify the root of the problem.

    Code:
    SHOW VARIABLES LIKE  '%olla%';
     
    cclaerhout likes this.
  3. Saburov

    Saburov Active Member

    Hi

    I Don't know mysql very well. Where will i write this querry?
     
  4. Jon W

    Jon W Well-Known Member

    If you have something like phpMyAdmin installed on your server, you should just be able to type the above in the SQL query box and it will give you a result like this:
    Code:
    Variable_name        Value
    collation_connection utf8_general_ci
    collation_database   latin1_swedish_ci
    collation_server     latin1_swedish_ci
     
    Saburov likes this.
  5. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Saburov likes this.
  6. Saburov

    Saburov Active Member

    Sorry i'm late. My results are this:

    Variable_name Value
    collation_connection utf8_general_ci
    collation_database latin1_swedish_ci
    collation_server latin1_swedish_ci
     
  7. Saburov

    Saburov Active Member

  8. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Your error message names the message column, not title. It should be in xf_post.
     
    Saburov likes this.
  9. Saburov

    Saburov Active Member

    it's turkish but you can see all of the options are utf8_general_ci in xf_post. it's weird.

    xf_post.png
     
  10. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    What message are you posting that causes this error? Are you able to post it here?
     
  11. Saburov

    Saburov Active Member

  12. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    I have no problems posting that message with utf8 collations.

    I can take a look if you give me FTP and admin access.
     

Share This Page