1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mysqli statement execute error : Got a packet bigger than 'max_allowed_packet' bytes

Discussion in 'Installation, Upgrade, and Import Support' started by imno007, Jun 7, 2013.

  1. imno007

    imno007 Active Member

    Hello. I was trying to do a test import from VB 3.8 and getting this error. This is the rest of the error message:

    1. Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 297
    2. Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
    3. Zend_Db_Adapter_Abstract->query() in XenForo/Model/Permission.php at line 1591
    4. XenForo_Model_Permission->rebuildContentPermissionCombination() in XenForo/Model/Permission.php at line 1551
    5. XenForo_Model_Permission->rebuildPermissionCombination() in XenForo/Model/Permission.php at line 1453
    6. XenForo_Model_Permission->rebuildPermissionCache() in XenForo/Importer/vBulletin.php at line 1655
    7. XenForo_Importer_vBulletin->stepForums() in XenForo/Importer/Abstract.php at line 77
    8. XenForo_Importer_Abstract->runStep() in XenForo/ControllerAdmin/Import.php at line 180
    9. XenForo_ControllerAdmin_Import->_runStep() in XenForo/ControllerAdmin/Import.php at line 132
    10. XenForo_ControllerAdmin_Import->actionImport() in XenForo/FrontController.php at line 313
    11. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
    12. XenForo_FrontController->run() in /home/wordhave/public_html/xenforo/admin.php at line 13
    This occurs when I try importing the forums. Now I know the obvious answer is going to be that the host needs to increase the max_allowed_packet size. However, I have been assured by my host that the present limit is 512 MB. It was already 256 MB and the host increased it after I reported this error. I can't believe it would require more than that. I could run IPB fine with a 32 MB limit.

    I also ran the the test script to make sure the host meets all the requirements, and I'm not seeing anything lacking there. But I don't claim to be a whiz with these things. Can someone tell me what I might be missing here? TIA

    EDIT: I probably should have put this in the import forum, so feel free to move it.
     
    Last edited: Jun 7, 2013
  2. Brogan

    Brogan XenForo Moderator Staff Member

    XenForo handles things differently compared to other software so comparisons aren't really valid.

    The error is related to permissions combinations, which can be complex depending on how many user groups and nodes you have.

    Try increasing it again if you can.

    Edit: Moved ;)
     
  3. imno007

    imno007 Active Member

    Thanks. Yes, I suspect this might have to do with the atypical way Xenforo displays nested boards by default - and I have a great many of them. I'll ask for another limit increase. ;)
     
  4. Mike

    Mike XenForo Developer Staff Member

    Are you sure they're actually increasing the max packet size in MySQL? The numbers you give sound more like PHP memory limits... You can actually confirm the setting with this query:
    Code:
    SHOW VARIABLES LIKE 'max_allowed_packet';
    I should note that 1.2 does change things to not have this particular issue.
     
    Brogan likes this.
  5. imno007

    imno007 Active Member

    I think you 're right, Mike! Guess I should have thought of doing that myself, but I thought these guys knew what they were doing, especially since I had to have them increase this limit in the past on another server for IPB. And I showed them the exact same error message I posted above. But I ran the query and the current value is: 1048576. Isn't that just 1 MB?
     
    Last edited: Jun 8, 2013
  6. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Yes.
     
  7. imno007

    imno007 Active Member

    Thanks, Jake. Even to me, I thought those numbers for max packet size sounded high, because I remembered that I only had to have it increased to 32 MB for IPB to run smoothly with all the bells and whistles, but I really didn't know enough about it to recognize just how excessive 512 MB might be. Anyway, I'm waiting to hear back from the host now, hopefully I can get it sorted out soon.
     
  8. imno007

    imno007 Active Member

    Turns out it was not a question of the host not knowing what settings needed to be changed. They told me that the MySQL max packet size really should be 512 MB and I gather they don't know why mine isn't. The guy who responded to me said he'd even "checked with a couple of users" to verify they had the proper limit, and apparently they do. So I've no idea what's going on. Waiting to hear back from them again... ;)
     
  9. imno007

    imno007 Active Member

    Just thought I'd end this by announcing that my max-packet limit was finally, truly, increased to 512 MB and the forum import went as smooth as butter. The host never told me exactly what the issue was, and I never asked, in case it was something embarrassing like they just needed to restart the server or something, but all's good now.

    I guess the lesson learned here is that the error is, more often than not, exactly the one you're seeing. ;)

    Thanks again to those who responded.
     

Share This Page