1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MySQLi Error

Discussion in 'Troubleshooting and Problems' started by Storm3y, Aug 4, 2012.

  1. Storm3y

    Storm3y Member


    I appear to be getting the following MySQLi error when trying to install a new plugin and rebuild the cache.
    MySQL Appears to be running as we can browse the forum etc.

    Any idea to why we are getting this error?

    An exception occurred: Mysqli prepare error: MySQL server has gone away in /home/cgshiny/public_html/library/Zend/Db/Statement/Mysqli.php on line 77
    Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
    Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
    Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
    Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 825
    Zend_Db_Adapter_Abstract->fetchOne() in XenForo/Error.php at line 50
    XenForo_Error::unexpectedException() in XenForo/Application.php at line 295

    Tnx :)
  2. BamaStangGuy

    BamaStangGuy Well-Known Member

    Need to up your wait_timeout setting in /etc/my.cnf
  3. Storm3y

    Storm3y Member

    Hello, what would you recommend?
  4. BamaStangGuy

    BamaStangGuy Well-Known Member

    What is it currently? wait_timeout=60 should be enough. You can lower it from there to see where your limit it.
  5. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

Share This Page