XF 1.3 MySql prepare error?

kiracastle

New member
Hi there,

I've just uploaded xenforo 1.3 to a new website and adjusted the config.php file (in libraries for the db) to point to the database however I get this error.

(the db is brand new)

Just wondering if anyone knows the fix for this issue? Thanks heaps.

Server Error
Mysqli prepare error: Table 'minesauce.xf_data_registry' doesn't exist

  1. Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
  2. Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
  3. Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
  4. Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 825
  5. Zend_Db_Adapter_Abstract->fetchOne() in XenForo/Model/DataRegistry.php at line 64
  6. XenForo_Model_DataRegistry->_getFromDb() in XenForo/Model/DataRegistry.php at line 34
  7. XenForo_Model_DataRegistry->get() in XenForo/Application.php at line 730
  8. XenForo_Application->loadOptions()
  9. call_user_func_array() in XenForo/Application.php at line 922
  10. XenForo_Application->lazyLoad() in XenForo/Application.php at line 953
  11. XenForo_Application::get() in XenForo/Model/User.php at line 943
  12. XenForo_Model_User->getVisitingGuestUser() in XenForo/Visitor.php at line 419
  13. XenForo_Visitor::setup() in XenForo/Install/Controller/Upgrade.php at line 50
  14. XenForo_Install_Controller_Upgrade->_setupSession() in XenForo/Controller.php at line 304
  15. XenForo_Controller->preDispatch() in XenForo/FrontController.php at line 346
  16. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
  17. XenForo_FrontController->run() in/hermes/bosoraweb012/b116/dom.haydzcraftcom1/public_html/minesauce/forums/install/index.php at line 18
 

Brogan

XenForo moderator
Staff member
Is this an existing installation or a new one?
The error indicates the table is missing from the database.
 

Jake Bunce

XenForo moderator
Staff member
That appears to indicate that you copied the files for an existing installation but not the database.

For a new install you need to empty data and internal_data. Then it will prompt you to run a new install.

Or to move an existing forum you must also copy the database.
 

kiracastle

New member
Thank you Jake, that's exactly what I needed to do. :D Sorry for my noobiness. But its all great now! Cheers
 
Top