1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 "MySQL Has Gone Away" On Registration

Discussion in 'Troubleshooting and Problems' started by Teapot, Feb 10, 2014.

  1. Teapot

    Teapot Well-Known Member

    Odd problem here. We're getting the infamous "MySQL has gone away" problem when some (but not all) users try to register on our site, after they click Submit. The stack trace is as follows:

    Code:
    An exception occurred: Mysqli prepare error: MySQL server has gone away in /home/pcharms/public_html/library/Zend/Db/Statement/Mysqli.php on line 77
        Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
        Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
        Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
        Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 808
        Zend_Db_Adapter_Abstract->fetchPairs() in XenForo/Phrase.php at line 332
        XenForo_Phrase::loadPhrases() in XenForo/Template/Abstract.php at line 186
        XenForo_Template_Abstract->render() in XenForo/Template/Public.php at line 110
        XenForo_Template_Public->render() in NodesAsTabs/NavTabs.php at line 126
        NodesAsTabs_NavTabs::createNodeTabs()
        call_user_func_array() in XenForo/CodeEvent.php at line 90
        XenForo_CodeEvent::fire() in XenForo/Dependencies/Public.php at line 491
        XenForo_Dependencies_Public->_getNavigationContainerParams() in XenForo/Dependencies/Public.php at line 371
        XenForo_Dependencies_Public->getEffectiveContainerParams() in XenForo/FrontController.php at line 612
        XenForo_FrontController->renderView() in XenForo/FrontController.php at line 158
        XenForo_FrontController->run() in /home/pcharms/public_html/index.php at line 13
    
    Originally thinking this was load, we tried restarting the server and getting the user to register immediately afterwards with the load at minimum, with no effect. We also disabled listeners (to forcibly disable the CPU-hungry application we use and to ensure no add-on issues were causing the problem.

    We're on an Apache 2.4 box with MySQL 5.5, PHP 5.5, Memcached, and the Zend Opcache, if that helps any.
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    That error is caused by one of these MySQL settings being exceeded:

    wait_timeout
    max_allowed_packet

    Your host or server person needs to increase these settings in MySQL. There is more info here:

    http://dev.mysql.com/doc/refman/5.1/en/gone-away.html
     
    McKel likes this.
  3. Teapot

    Teapot Well-Known Member

    Thanks, I'll try increasing both settings and get back to you if they help any.
     

Share This Page