• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

MySQL DB error - Locked out of admin

Adam K M

Active member
#1
Hello, the following error just started randomly happening, it would be great if anyone has any idea how to fix it.
I can't login to the admin control panel either!
[syntax]
An exception occurred: Mysqli statement execute error : Prepared statement needs to be re-prepared in /home/shortcut/public_html/forums/library/Zend/Db/Statement/Mysqli.php on line 214

Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 297
Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
Zend_Db_Adapter_Abstract->query() in XenForo/Model.php at line 219
XenForo_Model->fetchAllKeyed() in EWRporta/Block/RecentThreads.php at line 69
EWRporta_Block_RecentThreads->getThreads() in EWRporta/Block/RecentThreads.php at line 30
EWRporta_Block_RecentThreads->getBypass() in EWRporta/Model/Blocks.php at line 135
EWRporta_Model_Blocks->getBlockParams() in EWRporta/ViewPublic/Custom.php at line 71
EWRporta_ViewPublic_Custom->renderHtml() in XenForo/ViewRenderer/Abstract.php at line 217
XenForo_ViewRenderer_Abstract->renderViewObject() in XenForo/ViewRenderer/HtmlPublic.php at line 67
XenForo_ViewRenderer_HtmlPublic->renderView() in XenForo/FrontController.php at line 533
XenForo_FrontController->renderView() in XenForo/FrontController.php at line 156
XenForo_FrontController->run() in /home/shortcut/public_html/forums/index.php at line 13
[/syntax]
 

Adam K M

Active member
#7
Do it in WHM, if you don't have root access, you'll need to request it from your host.
Thank you, you two!
My forums are back and running! :)
Cancel that...
After the restart it appears to be happening again.....
It is not happening 100% of the time, but it happens for stretches of time and is really annoying, I also believe it is heavily affecting site performance! :(
I have no idea what could be causing it... in cPanel I have enough bandwith, storage, ect....

Any ideas?
It's happening to everyone, and some better insight would be great!
The error that's happening in the FTP is this:

Error Log - Only copied the most recent stuff
[syntax]
[30-May-2013 21:17:31 America/New_York] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20090626/perl.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20090626/perl.so: cannot open shared object file: No such file or directory in Unknown on line 0
[30-May-2013 21:17:42 America/New_York] PHP Warning: Module 'zip' already loaded in Unknown on line 0
[30-May-2013 21:17:42 America/New_York] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20090626/perl.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20090626/perl.so: cannot open shared object file: No such file or directory in Unknown on line 0
[30-May-2013 21:17:50 America/New_York] PHP Warning: Module 'zip' already loaded in Unknown on line 0
[30-May-2013 21:17:50 America/New_York] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20090626/perl.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20090626/perl.so: cannot open shared object file: No such file or directory in Unknown on line 0
[/syntax]
 

Adam K M

Active member
#11
They did so, and well I'm not sure if that fixed anything or not, but I just got

An exception occurred: Mysqli statement execute error : Prepared statement needs to be re-prepared in /home/shortcut/public_html/forums/library/Zend/Db/Statement/Mysqli.php on line 214

Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 297
Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 825
Zend_Db_Adapter_Abstract->fetchOne() in XenForo/Error.php at line 50
XenForo_Error::unexpectedException() in XenForo/Application.php at line 309
XenForo_Application::handleException()
The same perl error is happening again...
[30-May-2013 23:35:03 America/New_York] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20090626/perl.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20090626/perl.so: cannot open shared object file: No such file or directory in Unknown on line 0