• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.1 mybb to xenforo

avi

Active member
#1
I am trying to convert my mybb forum to xf. But I am not getting which is the best approach. And I don't care about catering user passwords.

So which one ? via vB or IPB ?

tia :)

PS - Please don't suggest me paid services & all. I want to try out myself & also my mybb forum is quite small :p
 

Andrej

Well-known member
#2
It depends on if you have a license for vB or IPB. If you have both, I would go the IPB way... vBulletin is full of bugs and I don't trust the Impex importer.
 

avi

Active member
#4
It depends on if you have a license for vB or IPB. If you have both, I would go the IPB way... vBulletin is full of bugs and I don't trust the Impex importer.
Oh, I didn't know about vB & bugs thing.

I just had a quick conversion from myBB to IPB, everything seems correct :D And passwords have been catered successfully !
 

avi

Active member
#6
mybb to IPB was very quick, but IPB to xF took a lot of time !

Everything seems fine. But only problem is with my account. It is now a latest member and post count to set to 1 ! It is still first member of the forum, members/avi.1

I rebuilt all caches again, still the issue is there.

Any help ?
 

Carlos

Well-known member
#7
I was going to say rebuild caches - run through the entire list...

But I guess you already did and the issue is still there. Brogan!
 

Jake Bunce

XenForo moderator
Staff member
#10
Floris is talking about this cron:

Admin CP -> Tools -> Cron Entries -> Rebuild Board Totals Counter

It runs automatically. Just give it time. Or you can run it manually to force those stats to update.
 

avi

Active member
#12
jake - Thank you ! I ran the cron entry thing, it did not work. I ran your SQL query, I did ! It showed 15 rows affected, that means there was problem with 15 users with their post counts...

but any idea why that happened ?
 

Jake Bunce

XenForo moderator
Staff member
#15
jake - Thank you ! I ran the cron entry thing, it did not work. I ran your SQL query, I did ! It showed 15 rows affected, that means there was problem with 15 users with their post counts...

but any idea why that happened ?
I am guessing the user post counts were not correct in IPB. When you import to XenForo it preserves the post counts from IPB.
 

avi

Active member
#16
@floris - thank you !

@jake - Post counts in IPB are fine and also how come I became latest member (in sidebar which appears on homepage)
 

avi

Active member
#18
I got it how. In my old forum, my username is Avi. While installing IPB I used same username, so may be that's why the problem has occurred. I will do import job again & see

Can you tell me hoe shall I reinstall xenforo & IPB again OR do I have to clear DB and run the installer again