XF 2.2 My XF keeps redirecting to an old WP admin url...

drastic

Well-known member
Hey,

I moved my old WP blog to domain.com/blog

I moved my XF install to the main dir.

Both the blog and XF function - except when I go to the XF homepage, it keeps trying to redirect to the WP admin for some reason. Don't really care for the WP install and only want XF to work - but of course, I got the opposite haha!

Been trying to figure this out and surely, I'm stuck.

Any suggestions?

Thanks!
 

drastic

Well-known member
I may have figured it out. Old public nav links might be trying to access something no longer there...

I tried to edit the nav link, but got this error:

ErrorException: [E_WARNING] file_put_contents(/home/httpd/html/domain.com/public_html/internal_data/code_cache/navigation_cache.php): failed to open stream: Permission denied in src/vendor/league/flysystem/src/Adapter/Local.php at line 199

  1. XF::handlePhpError()
  2. file_put_contents() in src/vendor/league/flysystem/src/Adapter/Local.php at line 199
  3. League\Flysystem\Adapter\Local->update() in src/vendor/league/flysystem/src/Filesystem.php at line 99
  4. League\Flysystem\Filesystem->put()
  5. call_user_func_array() in src/vendor/league/flysystem-eventable-filesystem/src/EventableFilesystem.php at line 431
  6. League\Flysystem\EventableFilesystem\EventableFilesystem->callFilesystemMethod() in src/vendor/league/flysystem-eventable-filesystem/src/EventableFilesystem.php at line 395
  7. League\Flysystem\EventableFilesystem\EventableFilesystem->delegateMethodCall() in src/vendor/league/flysystem-eventable-filesystem/src/EventableFilesystem.php at line 57
  8. League\Flysystem\EventableFilesystem\EventableFilesystem->put() in src/vendor/league/flysystem/src/MountManager.php at line 597
  9. League\Flysystem\MountManager->put() in src/XF/Util/File.php at line 197
  10. XF\Util\File::writeToAbstractedPath() in src/XF/Repository/Navigation.php at line 113
  11. XF\Repository\Navigation->rebuildNavigationCache() in src/XF/Entity/Navigation.php at line 316
  12. XF\Entity\Navigation->XF\Entity\{closure}() in src/XF.php at line 318
  13. XF::triggerRunOnce() in src/XF/Mvc/Dispatcher.php at line 156
  14. XF\Mvc\Dispatcher->dispatchLoop() in src/XF/Mvc/Dispatcher.php at line 55
  15. XF\Mvc\Dispatcher->run() in src/XF/App.php at line 2300
  16. XF\App->run() in src/XF.php at line 465
  17. XF::runApp() in admin.php at line 13
 

drastic

Well-known member
I checked several spots in the options to update homepage url. Got that done. Not sure what else to check.

First time I've ever seen this and I've moved XF around to different directories a few times without issues.... very odd.... rebuilt master data... nothing.
 
Last edited:
Top