XF 2.2 My website is gone: first HTTP ERROR 500 and after database backup it say that it is under maintenance ? What can I do?

NandorHUN

Active member
Hi Guys!

I wanted to do the last bits on my XF Forum but I wasnt able to do it myself so I ordered a guy from Fiverr to do some widget configuration on my site (added him as a regulard admin)...

Well the reasult isnt so good:
basically my site is gone:
I got HTTP ERROR 500. He say the issue is with my provider but an upladed index.php work fine, so the issue is with XF itself.

I asked to recover the database from the morning they did but the website is still a mess: I basically lost everything: months of work, my nodes, contents, and the site say " it is under maintenance". I cant even log in with my admin.

What can I do? Any tip, help?
I worked a lot on this site, if I can save any of it I would be happy to.

Thanks a lot for the help!
 

NandorHUN

Active member
Since you have the DB you should be able to reload the Xen software and be good once again.
My provider said he reuploaded the backup (he had the files) and before that I also backuped the files from yesterday (the database is from this morning), but for some reason my site is still gone.
I can go to the domain and it does show XF, but it say XF is being upgraded (like Im currently installing an upgrade or something).
 

NandorHUN

Active member
You could try going to
Code:
https://yoursite.com/install
I got this error:

Error: Class 'League\Flysystem\AwsS3v3\AwsS3Adapter' not found in src/config.php at line 28
  1. XF\App->{closure}()
  2. call_user_func() in src/XF/FsMounts.php at line 17
  3. XF\FsMounts::loadDefaultMounts() in src/XF/App.php at line 1097
  4. XF\App->XF\{closure}() in src/XF/Container.php at line 28
  5. XF\Container->offsetGet() in src/XF/App.php at line 2566
  6. XF\App->fs() in src/XF.php at line 908
  7. XF::fs() in src/XF/Util/File.php at line 738
  8. XF\Util\File::installLockExists() in src/XF/Install/Helper.php at line 474
  9. XF\Install\Helper->isInstalled() in src/XF/Install/Controller/Index.php at line 11
  10. XF\Install\Controller\Index->actionIndex() in src/XF/Mvc/Dispatcher.php at line 350
  11. XF\Mvc\Dispatcher->dispatchClass() in src/XF/Mvc/Dispatcher.php at line 257
  12. XF\Mvc\Dispatcher->dispatchFromMatch() in src/XF/Mvc/Dispatcher.php at line 113
  13. XF\Mvc\Dispatcher->dispatchLoop() in src/XF/Mvc/Dispatcher.php at line 55
  14. XF\Mvc\Dispatcher->run() in src/XF/App.php at line 2326
  15. XF\App->run() in src/XF.php at line 488
  16. XF::runApp() in install/index.php at line 14

Opera Pillanatfelvétel_2021-02-.png
 

NandorHUN

Active member
If you are not able to log in to your ACP you got a problem.

It seems you installed the S3 add-on before. I guess it's this one or you setup this?
Even so, if I log in I get this message and I cant do anything:

"The site is currently being upgraded. Please check back later." Same message, even if I click on the Add-ons.
 

duderuud

Well-known member
If you setup S3 using @Chris D's guide you need to add this to your config.php: (change xftest to your config setting)

Code:
$config['fsAdapters']['data'] = function() use($s3)
{
   return new \League\Flysystem\AwsS3v3\AwsS3Adapter($s3(), 'xftest', 'data');
};
 

NandorHUN

Active member
If you setup S3 using @Chris D's guide you need to add this to your config.php: (change xftest to your config setting)

Code:
$config['fsAdapters']['data'] = function() use($s3)
{
   return new \League\Flysystem\AwsS3v3\AwsS3Adapter($s3(), 'xftest', 'data');
};
It is added.... and even if it wasnt would be the error?

As I said I set it up weeks ago, and it worked, until this guy messed up my site this evening.

I can copy my whole config file here but here's the part:


$config['fsAdapters']['data'] = function() use($s3)
{
return new \League\Flysystem\AwsS3v3\AwsS3Adapter($s3(), 'mysite', 'data');
};

$config['externalDataUrl'] = function($externalPath, $canonical)
{
return 'https://v.fra1.digitaloceanspaces.com/data/' . $externalPath;
};

$config['fsAdapters']['internal-data'] = function() use($s3)
{
return new \League\Flysystem\AwsS3v3\AwsS3Adapter($s3(), 'mysite', 'internal_data');
};

$config['internalDataUrl'] = function($externalPath, $canonical)
{
return 'https://mysite.fra1.digitaloceanspaces.com/internal_data/' . $externalPath;
};
 

NandorHUN

Active member
Ok Guys!
I was able to solve it.

Though it would have been much easier if the guy told me what he actually do instead of saying "he didnt do anything" so I have to figure it out all by myself.
He turned off all of the add-ons and for some reason it gave me HTTPS ERROR 500 and I wasnt even able to reach the ACP.
I loaded an old database with that somehow I was able to access the ACP and I see the S3 Amazon Error, I deleted that part from the ftp src/config file.
After that I was able to access the ACP and see that every add-on was turned off except for one, so I set it up, reloaded the newest database and rewrote the config file as it was originally.


So yeah... use fiver with causion. I still need his help, with some stuff but in the future I will be very careful.... and only let external help in if I have to.
 

NandorHUN

Active member
Wow. This is why I never use Fiverr. :(
There are stuff that I cant do and rather I would pay if he can do it for a lot less then my time costs.

For example one guy fixed mobile view on my XF site.
This time I asked him to fix a Chat 2 widget and modify custom user fields. Im sure I would be able to do it too, but it would take hours to fighure out what's wrong... even now I asked the Dev in Chat 2 by Siropu what's wrong with his iframe widget and no answer...
 
Top