1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

My site is down

Discussion in 'Troubleshooting and Problems' started by 3rd AnGle, Mar 14, 2012.

  1. 3rd AnGle

    3rd AnGle Well-Known Member

    Just as my license expired... this error came up. :cry:

    Just two days back one of our Mod complained that he got a warning message about presence of malware in our site from google too..

    could someone explained the real issue pleassssseeeeeee??


    An exception occurred: Cannot send headers; headers already sent in /home/hippy/public_html/xxxxxxx.com/index.php, line 22 in /home/hippy/public_html/xxxxx.com/library/Zend/Controller/Response/Abstract.php on line 321
    1. Zend_Controller_Response_Abstract->canSendHeaders() in Zend/Controller/Response/Abstract.php at line 115
    2. Zend_Controller_Response_Abstract->setHeader() in XenForo/ViewRenderer/HtmlPublic.php at line 19
    3. XenForo_ViewRenderer_HtmlPublic->__construct() in XenForo/Dependencies/Public.php at line 190
    4. XenForo_Dependencies_Public->getViewRenderer() in XenForo/FrontController.php at line 499
    5. XenForo_FrontController->_getViewRenderer() in XenForo/FrontController.php at line 139
    6. XenForo_FrontController->run() in /home/hippy/public_html/bbbbbbbbb.com/index.php at line 38
     
  2. ragtek

    ragtek Guest

    Did you (or the malware change any files?)


    The error means=> http://xenforo.com/community/threads/apc-problems.23146/

    So it seems that the malware edited some files.
    have you an managed webspace or an own server? try to contact the admin so he can check what exactly was "injected"
     
  3. 3rd AnGle

    3rd AnGle Well-Known Member

    I didn't.. i don't know about the malware. How can i check it in my files?

    I have just contacted my server provider... what exactly shoul i ask them to do?


    THANKs a lot for your help btw
     
  4. 3rd AnGle

    3rd AnGle Well-Known Member

    my site works well on chrome.... but not in FF n IE

    which files shud i be checking? Mike said "you may have added code before the <?php tag. Everything needs to be after that." in the other case. Where exactly should i be looking for those lines of code?
     
  5. ragtek

    ragtek Guest

    you could try to run : acp => tools => file health check to see if some of the original xf files were changed
     
    bambua likes this.
  6. 3rd AnGle

    3rd AnGle Well-Known Member

    okay... loooks like the index.php and install/index.php

    1. index.php File does not contain expected contents.
    2. install/index.php File does not contain expected contents.
     
  7. ragtek

    ragtek Guest

    then check if uploading the original files (at least the 2 corrupted) will help:)
     
  8. 3rd AnGle

    3rd AnGle Well-Known Member

    yup Ragtek i am replacing with the original and we re up now...

    BTW i was working on abstract.php and made this changes and it worked :p

    canSendHeaders(true) --> canSendHeaders(false)

    but now i changed it back to the originals


    THANK YOU RAGTEK...


    oooeee.. now how do i find the culprit and make sure it doesn;t happen again.. should i beat the crap out of my server provider or is it me.. we are on shared server btw
     
  9. bambua

    bambua Well-Known Member

    If you are on a shared server, depending on how it was set up, if someone compromises any accounts on the server it can be possible for them to get to any other account :/

    It really just depends, who is your hosting with?
     
    3rd AnGle likes this.

Share This Page