XF 2.0 My forums site is not showing up in Google search

ck_jun

New member
Hi all,

My site has been active since about 2 months ago, but when I search the subject matter of my forum, its not showing up in Google.

I've made most of the forums content available to view only by registered members. Will that be a reason?

Is there any code I should tweak or add to the site to increase my ranking?
 

Taminoful

Member
I've made most of the forums content available to view only by registered members. Will that be a reason?
Well, Google can't index your pages if they only can be read by registered users so that's most likely the reason for your page not showing up in any results. You should check your site with Google Search Console to check how the GoogleBot sees your website.
 
Last edited:

ck_jun

New member
Well, Google can't index your pages if they only can be read by registered users so that's most likely the reason for your page not showing up in any results. You should check your site with Google Search Console to check how the GoogleBot sees your website.
I see.. what other ways can i use to make it searchable via keywords? Add tags, extra coding, buy some plugin, etc?

Coz making it readable by guests is not something i wanna do for this forum
 

djbaxter

Well-known member
Search engine spiders are guests / unregistered users / non-logged in members.

If you want search engines to index your content, you need to make the content visible to non-logged in visitors and guests.

There is no other option.
 

Mr Lucky

Well-known member
If your intention is for content to be only viewable by your users, it makes no sense to have the links public. Even if that was possible on Google, people would follow the link and then find nothing they can see.

I do know there may be an add on that shows only the first or first x no of posts of a thread publically, that might be useful for you.

In this case google would at least be able to index the first post
 

Mr Lucky

Well-known member
This one

 
Top