1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

More search terms = more results? Very common search terms = few results?

Discussion in 'Enhanced Search Support' started by kontrabass, Jul 3, 2014.

  1. kontrabass

    kontrabass Well-Known Member

    So I just upgraded to XFES 1.1. Max results is set at 850.

    If I do a search for a single very common keyword like "ampeg", I only get maybe 160 results. That's not right - it should max out at 850. If I increase to two words ("ampeg b-15"), I get over 500 results. Same goes with searches like "ibanez" (179 results) vs "ibanez sr400" (700+ results).

    Is this intended behavior?
  2. Mike

    Mike XenForo Developer Staff Member

    If I search ordered by the most recent (rather than relevance), I get a large number of results for "ampeg". That would imply that it's matching a lot of records that possibly can't be seen by the user (I'm testing as a guest). In that case, it's as expected. Do you have a lot content that is hidden (possibly old and thus archived)?

    You may wish to enable recency-weighted relevancy sorting. It's not enabled by default as it may require some additional steps with elasticsearch.
  3. kontrabass

    kontrabass Well-Known Member

    I get the same behavior - results max out if sorted by recency, only 160 results or so by relevancy. I tried recency-weighted relevancy sorting just now - no effect on the number of results.

    I do not have content that is hidden (except for mod discussion etc). Everything "ampeg" or "ibanez" or "fender" is all public.

    Jeepers, searching for "fender" returns under 130 results. There are literally tens of thousands of posts about fender basses. Searching "fender jazz" returns 180 results, and "fender jazz bass" returns 225 results... interesting.

    Do I need to upgrade ES maybe? I'm on 0.90.7

    17,534,432 (5.7 GB)
    Index Updates:
    17,534,697 (0.0002 seconds average)
    3,975 (0.0395 seconds average)
    3,278 (0.0045 seconds average)
  4. Mike

    Mike XenForo Developer Staff Member

    Can you try rebuilding the search index? (I would probably choose to delete it before rebuilding.)
  5. kontrabass

    kontrabass Well-Known Member

    Will give it a shot. One more interesting info: if I search for "fender" in one node only (Basses), I get a 750 results. Searching whole board, I only get 112. Almost seems like it's not getting enough resources (memory?) to search the whole board with one popular keyword.
  6. kontrabass

    kontrabass Well-Known Member

    Rebuilding search index changed nothing. Huh. I'll try upgrading java and ES.
  7. Beanjam

    Beanjam Active Member

    I am seeing this too, did you ever find what the cause was?

Share This Page