• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Missing upload file button

Chris D

XenForo developer
Staff member
#2
This is a regression in Firefox but we have worked around it in XF 1.5.11.

At some point, a Firefox update should fix it, failing that, upgrading to XF 1.5.11 should sort it.
 

Bombardier

Active member
#3
I have just upgraded to the latest version and I use Chrome
If I enable HTML5 uploader the upload file button disappears, the same is seen using my Iphone browswer
when disabled the button reappears

Any ideas, most of whatI could find related to Firefox browsers so I am none the wiser
 

Chris D

XenForo developer
Staff member
#4
I recommend performing a file health check in Admin CP > Tools > File Health Check. It sounds like one or more of the new files could be missing.
 

Bombardier

Active member
#5
yes it has found some files stating File does not contain expected contents.
should I just upload them or do I need to go through the entire upgrade process again
 

Chris D

XenForo developer
Staff member
#6
Which files, specifically?

Obviously one of the attachment_editor_new.js files, I assume. But what about other files, such as PHP and XML files?

If there are any XML files missing or not matching the contents then you may need to rebuild master data (which is basically done from the install page, like the upgrade).
 

Bombardier

Active member
#7
well
language_en.php
Fb_channel.php

then all these from js

  1. js/xenforo/comments_simple.jsFile does not contain expected contents.
  2. js/xenforo/full/acp_forum_editor.jsFile does not contain expected contents.
  3. js/xenforo/full/attachment_editor.jsFile does not contain expected contents.
  4. js/xenforo/full/avatar_editor.jsFile does not contain expected contents.
  5. js/xenforo/full/acp_quicksearch.jsFile does not contain expected contents.
  6. js/xenforo/full/attachment_editor_new.jsFile does not contain expected contents.
  7. js/xenforo/full/acp_login.jsFile does not contain expected contents.
  8. js/xenforo/full/acp_nav.jsFile does not contain expected contents.
  9. js/xenforo/style_property_editor.jsFile does not contain expected contents.
  10. js/xenforo/xenforo.jsFile does not contain expected contents.
  11. js/xenforo/news_feed.jsFile does not contain expected contents.
  12. js/xenforo/rating.jsFile does not contain expected contents.
  13. js/xenforo/feed_preview.jsFile does not contain expected contents.
  14. js/xenforo/smiley_editor.jsFile does not contain expected contents.
  15. js/xenforo/acp_forum_editor.jsFile does not contain expected contents.
  16. js/xenforo/conversation_invite.jsFile does not contain expected contents.
  17. js/xenforo/form_filler.jsFile does not contain expected contents.
  18. js/xenforo/attachment_editor.jsFile does not contain expected contents.
  19. js/xenforo/options_censor.jsFile does not contain expected contents.
  20. js/xenforo/event_listener.jsFile does not contain expected contents.
  21. js/xenforo/template_edit.jsFile does not contain expected contents.
  22. js/xenforo/avatar_editor.jsFile does not contain expected contents.
  23. js/xenforo/lightbox.jsFile does not contain expected contents.
  24. js/xenforo/sidebar.jsFile does not contain expected contents.
  25. js/xenforo/acp_quicksearch.jsFile does not contain expected contents.
  26. js/xenforo/attachment_editor_new.jsFile does not contain expected contents.
  27. js/xenforo/discussion.jsFile does not contain expected contents.
  28. js/xenforo/inline_mod.jsFile does not contain expected contents.
  29. js/xenforo/title_prefix.jsFile does not contain expected contents.
  30. js/xenforo/cache_rebuild.jsFile does not contain expected contents.
  31. js/xenforo/permission.jsFile does not contain expected contents.
  32. js/xenforo/color_picker.jsFile does not contain expected contents.
  33. js/xenforo/acp_login.jsFile does not contain expected contents.
  34. js/xenforo/filter_list.jsFile does not contain expected contents.
  35. js/xenforo/acp_nav.jsFile does not contain expected contents.
  36. js/xenforo/file_uploader.jsFile does not contain expected contents.
  37. js/xenforo/bb_code_edit.jsFile does not contain expected contents.
  38. js/xenforo/discussion_list.jsFile does not contain expected contents.
  39. js/xenforo/spam_cleaner.jsFile does not contain expected contents.
  40. js/xenforo/personal_details_editor.jsFile does not contain expected contents.
  41. js/xenforo/quick_reply_profile.jsFile does not contain expected contents.
  42. js/xenforo/tag.jsFile does not contain expected contents.
  43. js/xenforo/follow.jsFile does not contain expected contents.
 

Chris D

XenForo developer
Staff member
#8
Fine. In that case, all you need to do is re-upload the files and that should be enough.

After re-uploading the files, you might want to run a file health check again just to make sure all files are present and correct. At that point the file uploader should work properly.