• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 Missing To addresses error

Robert F Schmitz

Well-known member
#1
I just upgraded a test install on localhost to the latest beta and was alerted to review the server error logs.

The error indicated Missing To addresses

Code:
library\Zend\Mail\Transport\Sendmail.php:173
Is this due to my XAMPP install or something else?
 

Robert F Schmitz

Well-known member
#4
Code:
Zend_Mail_Transport_Exception: Missing To addresses - library\Zend\Mail\Transport\Sendmail.php:173
Generated By: Unknown Account, Wednesday at 6:43 PM
Stack Trace
#0 C:\xampp\htdocs\xf12\library\Zend\Mail\Transport\Abstract.php(337): Zend_Mail_Transport_Sendmail->_prepareHeaders(Array)
#1 C:\xampp\htdocs\xf12\library\Zend\Mail.php(1194): Zend_Mail_Transport_Abstract->send(Object(Zend_Mail))
#2 C:\xampp\htdocs\xf12\library\XenForo\Model\MailQueue.php(58): Zend_Mail->send(Object(Zend_Mail_Transport_Sendmail))
#3 C:\xampp\htdocs\xf12\library\XenForo\Deferred\MailQueue.php(10): XenForo_Model_MailQueue->runMailQueue(9.9999940395355)
#4 C:\xampp\htdocs\xf12\library\XenForo\Model\Deferred.php(190): XenForo_Deferred_MailQueue->execute(Array, Array, 9.9999940395355, '')
#5 C:\xampp\htdocs\xf12\library\XenForo\Model\Deferred.php(313): XenForo_Model_Deferred->runDeferred(Array, 9.9999940395355, '', false)
#6 C:\xampp\htdocs\xf12\library\XenForo\Model\Deferred.php(266): XenForo_Model_Deferred->_runInternal(Array, NULL, '', false)
#7 C:\xampp\htdocs\xf12\deferred.php(15): XenForo_Model_Deferred->run(false)
#8 {main}
Request State
array(3) {
  ["url"] => string(34) "http://localhost/xf12/deferred.php"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(4) {
    ["_xfRequestUri"] => string(43) "/xf12/index.php?members/crash-test-dummy.2/"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfToken"] => string(8) "********"
    ["_xfResponseType"] => string(4) "json"
  }
}
@Mike, here you go. I noticed the day and time which was well after we left work last week. Not sure about that.
 
Last edited:

Mike

XenForo developer
Staff member
#5
Unfortunately, it's hard to know the exact cause from that deferred mail (since we don't have the full contents), but I have noticed a situation where this could potentially happen and have prevented the error there.