1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Missing IP Address

Discussion in 'Troubleshooting and Problems' started by FirstSword, Mar 25, 2016.

  1. FirstSword

    FirstSword Member

    Hello, my users are suddenly receiving a page saying "Server Error" when they try to reset their passwords. I tested under a dummy account and received the same error. I have the following server error on my log on the admin page:

    Zend_Service_ReCaptcha_Exception: Missing ip address - library/Zend/Service/ReCaptcha.php:460

    Can anyone help me figure out how to fix this?

    Thank you!
  2. Mike

    Mike XenForo Developer Staff Member

    If you look at recent posts, is there an IP logged for them? (An "IP" link.) Similarly, do you see IPs listed on the online members page (the full page)?
  3. FirstSword

    FirstSword Member

    On the Members Online Now page I do have IP addresses; I do NOT on recent threads.

    I figured out that the captcha feature was the problem. New users also couldn't register. They would fill out their information, the captcha, hit submit and get the Server error. Admin panel would log the same "missing IP address" server error, but reference the Captcha. I disabled that, and now they work, but I don't want to leave the Captcha disabled. Any thoughts?
  4. FirstSword

    FirstSword Member

    Note that I also tried to change the CAPTCHA from reCAPTCHA to Question & Answer CAPTCHA with no luck. It still errors outs.
  5. Mike

    Mike XenForo Developer Staff Member

    I'm surprised you're seeing IPs in the online user list since they should all be pulling from the same place. If you go to admin.php?tools/phpinfo and search for "REMOTE_ADDR", does it display your IP there?

    Essentially, I'm thinking that PHP isn't being passed the IP of the person connecting, which ReCAPTCHA needs (as do a few other systems) and XF is assumed to have access to. If that PHP info page doesn't show an IP, that is definitely the underlying problem and your host (or whoever configured PHP) should be able to help.

Share This Page