1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Migration Issue

Discussion in 'Troubleshooting and Problems' started by Mark Thompson, Jul 21, 2012.

  1. Mark Thompson

    Mark Thompson Member

    I've migrated my Forum to a bigger server today and the Front page of the forum is up BUT links to The individual Forums, threads search etc return a 404 error

    I am sure it's something simple can someone tell me where to start looking???
  2. Mark Thompson

    Mark Thompson Member

    No Problem fixed this.... Mod_rewrite wasn't switched on on the new server
  3. Mark Thompson

    Mark Thompson Member

    Ok, it wasn't mod rewrite ... that was enabled , but unticking the full friendly urls box fixed it.

    The .htaccess is in the root and looks fine...

    Any ideas
  4. Chris D

    Chris D XenForo Developer Staff Member

    I had a similar problem with some vBulletin redirection scripts.

    I believe you will have a file called Forum.php in your root (probably along with showthread.php etc.).

    Delete forum.php and the full friendly URLs will work again.
  5. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

  6. Mark Thompson

    Mark Thompson Member

    AllowOverride is enabled and so is mod_rewrite this is clearly shown because wordpress which lives in the root is working correctly, xenforo is installed at /Forum and the htaccess rules are in this folder, we have tried enabling rewrite base or commenting it out but it has no effect, we also tried making sure wordpress bypassed any requests to /Forum or /Forum/* but that didn't fix either.
    if we comment the Error404 line out of htaccess it renders the wordpress 404 page which suggests its pushing through the wordpress index.php and not the Xenforo one in /Forum - i have tried various combinations of rewrite rules in /Forum/.htaccess but none will stop the 404'ing when search friendly urls enabled
  7. CyclingTribe

    CyclingTribe Well-Known Member

    Just as a short test, try renaming the Wordpress .htaccess to htaccess (removing the full stop will disable it but keep the content intact) #mv .htaccess to htaccess

    Does that get the XF rewrites working correctly at "/forum"? (Don't forget to rename it back to .htaccess)
  8. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    I can take a look if you give me FTP and admin access. Sometimes that is easier with problems like this.
  9. Mark Thompson

    Mark Thompson Member

    Tried that.. no Joy...
  10. Mark Thompson

    Mark Thompson Member

    Thanks Jake, pm coming your way..
  11. Daniel 'RTRD'

    Daniel 'RTRD' Well-Known Member

    Did you fix it? What was the solution? I got the same problem.
  12. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    His problem was caused by some custom rewrite rules for amember. This was the fix:

  13. Daniel 'RTRD'

    Daniel 'RTRD' Well-Known Member

    I created a new thread here.

Share This Page