• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

merc NUNS (New User Notification System) [Paid] [Deleted]

Status
Not open for further replies.
R

ragtek

Guest
#1
ragtek submitted a new resource:

merc NUNS (New User Notification System) (version 1.2) - Welcome your new members with an Thread/Post/Profile Post/Conversation

As part of moving my add-ons to Mercenary Design, Robbo and i are very happy to present the next add-on release (first one: http://xenforo.com/community/resources/minimum-post-length.388/ )

This add-on allows you to create a welcome thread, welcome post, and/or welcome profile post.
It's also possible to start a welcome conversation and to send a notification mail to your team members about the new registered user!
View attachment 27022





We're providing...
Read more about this resource...
 
R

ragtek

Guest
#3
lol 15$? I have bought a Premium Membership on ragtek.org, and now i should pay for this Addon too?
Did you read the description?;)


(Attention: Everybody who is a premium user @ragtek.org doesn't need to update to this version!
We've only changed the add-on name and version number
We'll inform you, once there's a new version with new features...)
Of course nobody with an premium membership needs to pay for this version!

All the premium users will be imported to http://mercenarydesign.com.au/ soon
 

Gene Steinberg

Well-known member
#4
Glad to see you're back in the game. This add-on is worth every dollar and then some. It's a great way to welcome new members into a forum community and increase participation. I recommend it to all XenForo forum admins without hesitation.
 

Gene Steinberg

Well-known member
#6
I went through sort of a burn out some years ago; as a book author, I was churning out four or five a year (really!). Finally, it was just too much for so little return.
 

Edrondol

Well-known member
#10
Buying a premium at his site is disabled? Whoa. I just looked at that this morning. Mere hours ago. Maybe I'm glad I didn't pull the trigger.
 
R

ragtek

Guest
#11
It's disabled since some days because of the movement process to http://mercenarydesign.com.au/

And as i posted already, once we finished the moving to mercenarydesign all existing premium users will be imported and get 1 year access to ALL the moved add-ons from ragtek.org to mercenarydesign.com.au
 
#12
I got a question regarding the add-on.

When people register in my web-based game, they get a forum account automatically using the DataWriter API.

Does the notification system also triggers correctly when the new users is created with this API, instead of a user registering manually in XenForo?
 
R

ragtek

Guest
#13
I got a question regarding the add-on.

When people register in my web-based game, they get a forum account automatically using the DataWriter API.

Does the notification system also triggers correctly when the new users is created with this API, instead of a user registering manually in XenForo?
yes. this add-on "is hooked" to the xenforo user datawriter, BUT if you have problems, i'm sure that i could change the code of this add-on for you, because the notifications won't be sent automatic on creating of new users, instead they're "fired" after the user state changes
 
#14
The plugin installed fine. When I manually change the user state, it works. When I use my DataWriter function to create a user, there is no topic created. This is my code I'm using:

PHP:
function XenForoAddUser($username,$email,$location,$password)
{
global $fileDir;
$startTime = microtime(true);
 
 
require($fileDir . '/library/XenForo/Autoloader.php');
XenForo_Autoloader::getInstance()->setupAutoloader($fileDir . '/library');
 
XenForo_Application::initialize($fileDir . '/library', $fileDir);
XenForo_Application::set('page_start_time', $startTime);
XenForo_Application::disablePhpErrorHandler();
 
$writer = XenForo_DataWriter::create('XenForo_DataWriter_User');
 
$writer->set('username', $username);
$writer->set('email', $email);
$writer->set('location', $location);
$writer->set('signature', '[IMG]http://gtracer.net/userbanner/'.$username.'.png[/IMG]');
$writer->setPassword($password,$password);
$writer->set('user_group_id', XenForo_Model_User::$defaultRegisteredGroupId);
$writer->save();
}
So basically, the user gets created, but the welcome topic doesn't. :)
 
#16
Thanks ragtek for helping me out, it finally works!

I do have another issue though. I changed the phrases in the admin panel, for example, I changed 'ragtek_NUNS_text_welcomethread_message'

To:

'Please welcome {username} to the GTRacer community!'

But still it's the master value that shows up in the created thread.

Any ideas?
 
R

ragtek

Guest
#17
Thanks ragtek for helping me out, it finally works!

I do have another issue though. I changed the phrases in the admin panel, for example, I changed 'ragtek_NUNS_text_welcomethread_message'

To:

'Please welcome {username} to the GTRacer community!'

But still it's the master value that shows up in the created thread.

Any ideas?
did you change it in the right language? (and not master language)
 
#18
I only have one language installed, English (US)

I will wait untill the first new users registers in-game, to make sure it wasn't a cache problem or something.
 
R

ragtek

Guest
#20
OK, then it's again something with your automatic user creating function:(

today i have no time for this, but i'll try to reproduce it as soon as possible
 
Status
Not open for further replies.