1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

merc NUNS (New User Notification System) [Paid] [Deleted]

Discussion in 'Add-on Releases' started by ragtek, Mar 14, 2012.

Thread Status:
Not open for further replies.
  1. ragtek

    ragtek Guest

    ragtek submitted a new resource:

    merc NUNS (New User Notification System) (version 1.2) - Welcome your new members with an Thread/Post/Profile Post/Conversation

    Read more about this resource...
  2. Badboy

    Badboy Member

    lol 15$? I have bought a Premium Membership on ragtek.org, and now i should pay for this Addon too?
  3. ragtek

    ragtek Guest

    Did you read the description?;)

    Of course nobody with an premium membership needs to pay for this version!

    All the premium users will be imported to http://mercenarydesign.com.au/ soon
    Badboy likes this.
  4. Gene Steinberg

    Gene Steinberg Well-Known Member

    Glad to see you're back in the game. This add-on is worth every dollar and then some. It's a great way to welcome new members into a forum community and increase participation. I recommend it to all XenForo forum admins without hesitation.
    ragtek likes this.
  5. ragtek

    ragtek Guest


    yes, my "coding break":D is over,i've recovered from my burnout as much as possible and now it's time to make some steps forward:)
    Veer and Saeed like this.
  6. Gene Steinberg

    Gene Steinberg Well-Known Member

    I went through sort of a burn out some years ago; as a book author, I was churning out four or five a year (really!). Finally, it was just too much for so little return.
  7. Markos

    Markos Well-Known Member

    But now i need to buy every addon about you? Can't buy a premium membership?
  8. Edrondol

    Edrondol Well-Known Member

    If you buy a premium membership on his site, you get all of the apps. At least that how I read it.
  9. Markos

    Markos Well-Known Member

    Now is disabled...
  10. Edrondol

    Edrondol Well-Known Member

    Buying a premium at his site is disabled? Whoa. I just looked at that this morning. Mere hours ago. Maybe I'm glad I didn't pull the trigger.
  11. ragtek

    ragtek Guest

    It's disabled since some days because of the movement process to http://mercenarydesign.com.au/

    And as i posted already, once we finished the moving to mercenarydesign all existing premium users will be imported and get 1 year access to ALL the moved add-ons from ragtek.org to mercenarydesign.com.au
    petertdavis likes this.
  12. Gwynei

    Gwynei Member

    I got a question regarding the add-on.

    When people register in my web-based game, they get a forum account automatically using the DataWriter API.

    Does the notification system also triggers correctly when the new users is created with this API, instead of a user registering manually in XenForo?
  13. ragtek

    ragtek Guest

    yes. this add-on "is hooked" to the xenforo user datawriter, BUT if you have problems, i'm sure that i could change the code of this add-on for you, because the notifications won't be sent automatic on creating of new users, instead they're "fired" after the user state changes
  14. Gwynei

    Gwynei Member

    The plugin installed fine. When I manually change the user state, it works. When I use my DataWriter function to create a user, there is no topic created. This is my code I'm using:

    function XenForoAddUser($username,$email,$location,$password)
    $startTime microtime(true);
    $fileDir '/library/XenForo/Autoloader.php');
    XenForo_Autoloader::getInstance()->setupAutoloader($fileDir '/library');
    XenForo_Application::initialize($fileDir '/library'$fileDir);
    $writer XenForo_DataWriter::create('XenForo_DataWriter_User');
    So basically, the user gets created, but the welcome topic doesn't. :)
  15. ragtek

    ragtek Guest

    check our last conversation;)
  16. Gwynei

    Gwynei Member

    Thanks ragtek for helping me out, it finally works!

    I do have another issue though. I changed the phrases in the admin panel, for example, I changed 'ragtek_NUNS_text_welcomethread_message'


    'Please welcome {username} to the GTRacer community!'

    But still it's the master value that shows up in the created thread.

    Any ideas?
  17. ragtek

    ragtek Guest

    did you change it in the right language? (and not master language)
  18. Gwynei

    Gwynei Member

    I only have one language installed, English (US)

    I will wait untill the first new users registers in-game, to make sure it wasn't a cache problem or something.
  19. Gwynei

    Gwynei Member

    It's not working unfortunately.

    Some screenshots:



    But as said, the Master Value keeps active...
  20. ragtek

    ragtek Guest

    OK, then it's again something with your automatic user creating function:(

    today i have no time for this, but i'll try to reproduce it as soon as possible
Thread Status:
Not open for further replies.

Share This Page