• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.1 Members Producing Error

Chris D

XenForo developer
Staff member
#3
Hmm... Do you have a folder called "members" in your XenForo root?

That could cause a problem.

Also mod_security I think generates this error sometimes.
 

kingston

Well-known member
#4
An exception occurred: Declaration of XenPlus_Dom_Document::loadHTML() should be compatible with DOMDocument::loadHTML($source, $options = NULL) in /home/kingharrison/fierceforum/library/XenForo/Autoloader.php on line 119
  1. XenForo_Application::handlePhpError() in XenForo/Autoloader.php at line 119
  2. XenForo_Autoloader::autoload() in XenForo/Autoloader.php at line 119
  3. XenForo_Autoloader->autoload()
  4. spl_autoload_call() in XenPlus/Dom/Query.php at line 11
  5. XenPlus_Dom_Query->getDom() in XenTrader/Listener/TemplatePostRender.php at line 13
  6. XenTrader_Listener_TemplatePostRender->_memberList() in XenPlus/Listener/TemplatePostRender.php at line 13
  7. XenPlus_Listener_TemplatePostRender->execute() in XenPlus/Listener/Abstract.php at line 21
  8. XenPlus_Listener_Abstract::listen()
  9. call_user_func_array() in XenForo/CodeEvent.php at line 54
  10. XenForo_CodeEvent::fire() in XenForo/Template/Abstract.php at line 195
  11. XenForo_Template_Abstract->render() in XenForo/Template/Public.php at line 110
  12. XenForo_Template_Public->render() in XenForo/ViewRenderer/HtmlPublic.php at line 119
  13. XenForo_ViewRenderer_HtmlPublic->renderContainer() in XenForo/FrontController.php at line 565
  14. XenForo_FrontController->renderView() in XenForo/FrontController.php at line 156
  15. XenForo_FrontController->run() in /home/kingharrison/fierceforum/index.php at line 13
 

MattW

Well-known member
#5
An exception occurred: Declaration of XenPlus_Dom_Document::loadHTML() should be compatible with DOMDocument::loadHTML($source, $options = NULL) in /home/kingharrison/fierceforum/library/XenForo/Autoloader.php on line 119
  1. XenForo_Application::handlePhpError() in XenForo/Autoloader.php at line 119
  2. XenForo_Autoloader::autoload() in XenForo/Autoloader.php at line 119
  3. XenForo_Autoloader->autoload()
  4. spl_autoload_call() in XenPlus/Dom/Query.php at line 11
  5. XenPlus_Dom_Query->getDom() in XenTrader/Listener/TemplatePostRender.php at line 13
  6. XenTrader_Listener_TemplatePostRender->_memberList() in XenPlus/Listener/TemplatePostRender.php at line 13
  7. XenPlus_Listener_TemplatePostRender->execute() in XenPlus/Listener/Abstract.php at line 21
  8. XenPlus_Listener_Abstract::listen()
  9. call_user_func_array() in XenForo/CodeEvent.php at line 54
  10. XenForo_CodeEvent::fire() in XenForo/Template/Abstract.php at line 195
  11. XenForo_Template_Abstract->render() in XenForo/Template/Public.php at line 110
  12. XenForo_Template_Public->render() in XenForo/ViewRenderer/HtmlPublic.php at line 119
  13. XenForo_ViewRenderer_HtmlPublic->renderContainer() in XenForo/FrontController.php at line 565
  14. XenForo_FrontController->renderView() in XenForo/FrontController.php at line 156
  15. XenForo_FrontController->run() in /home/kingharrison/fierceforum/index.php at line 13
Only reference I can find to that is with the XenTrader add-on and PHP 5.4

Are you running XenTrader?

http://xenforo.com/community/threads/xentrader.27673/page-2#post-376339
 

MattW

Well-known member
#7
Were you running the latest version of XenTrader? There was a fix on the following page, but I downloaded a copy, and the fix appeared to be included.