1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Members Have Avatars Even The Usergroup They are In Doesn't Allowed That

Discussion in 'XenForo Questions and Support' started by Shyuan, Sep 21, 2012.

  1. Shyuan

    Shyuan Well-Known Member

    Hi,

    My members who signed up will be placed in a usergroup "Member", here the members cannot upload avatars.

    Until they posted 15 messages, they will be promoted to another usergroup "Advanced Member", here they can upload avatars.

    But there are somehow a few people get through and able to have their own avatars even they have only zero message posted.

    I did not allow Facebook signup.

    Is it due to the gravatar? But I have already checked, they do not have the option to change Avatar under their personal details area, so what's more choosing the option gravatar?

    Thanks.
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    There is only this permission. Check it for all relevant groups:

    Admin CP -> Users -> List User Groups -> [click a group] -> Upload an avatar

    I don't think so. The same permission is checked for gravatars as well.
     
  3. Shyuan

    Shyuan Well-Known Member

    This was set to No. I created two demo accounts. They do not have any way to change/upload avatars, only when they reach 15 posts (promotion) they will be able to see the upload avatar option.

    I also tested on the particular member's (who was able to upload an avatar) permission, it doesn't show any upload avatar option. Not sure how he gets through. :/
     
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    What about your Unregistered / Unconfirmed group? Those permissions can apply to new registrations if they are awaiting email confirmation or moderation.
     
  5. Shyuan

    Shyuan Well-Known Member

    Hi Jake, sorry for the very late reply! I have just checked my Unregistered/Unconfirmed group, it appears to have the "Upload an avatar" set to "Not Set (No)". Also, "Maximum large avatar file size (bytes)" set to "0".

    I can't think of any other way for him to update/upload his avatar. :confused:
     
  6. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    I can take a look if you give me a URL and admin login.
     
  7. Shyuan

    Shyuan Well-Known Member

    Hi Jake, I have sent you the requested details. Thank you for offering help! :)
     
  8. Russ

    Russ Well-Known Member

    I had this problem for a bit it was just an email linked to gravatar.
     
    Shyuan likes this.
  9. Shyuan

    Shyuan Well-Known Member

    Oh! My Gravatar support was enabled! :eek: how can I missed that? :oops: Sorry Jake for wasting your time. My bad.

    And Thank you so much Russ! :D
     
  10. marioman

    marioman Active Member

    i have this problem now and my Gravatar option is disabled !!
     

Share This Page