• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Media Gallery

#1
Hey,

I have a presale question for media gallery that I hope someone can help me with?

I run a historic project out of Chattanooga, TN. We have about 29,000 photos to post. Can I set up the gallery where we're the only ones to post? We need a place where people can comment on each photo, but don't want to give other members the ability to post to the gallery.

Best,
David Moon
 

Brogan

XenForo moderator
Staff member
#2
The gallery is permission controlled so you can control it per user group or user with regards to who can upload media, comment on media, like, etc.
 

Brogan

XenForo moderator
Staff member
#6
The index page can be set to the gallery and you would just not create any forums.

Further tweaking could be done to remove/hide the tab, links, for the forums, etc.
 

Chris D

XenForo developer
Staff member
#10
Does the imagick PECL extension work on the demo for watermarks?
Yes it should be available on the demo and it is required for watermarks to be enabled.

I see where you can add a watermark, but can you add it to every image by default?
Yes, if you add a watermark it is added to every image, by default, but there are permissions which allow certain users or groups to bypass having the watermark created. The original image is stored, too, so if the image is ever manipulated (e.g. rotated, flipped, cropped) the watermark is re-applied to the original image, therefore avoiding a situation whereby you can end up with multiple watermarks on the image. Because we keep the original, users with permission can also remove the watermark from an already watermarked image.
 
#11
Thank you. I wasn't able to get that to work, maybe it's just a setting?

As a super admin I had to go to each photo and apply the watermark.
 

Chris D

XenForo developer
Staff member
#12
Not unsurprising. There is a permission for bypassing it, as I said above, and I believe it may be applied by default to moderators. You just need to adjust that permission.
 
#13
I'm still having an issue with getting images added to folders to automagically add the watermark. I have to manually go into the image and click on the watermark option. This is on the demo.