Maximum version number support for addon.json

DragonByte Tech

Well-known member
Currently, we can only specify a minimum version requirement in addon.json. This can produce a problem, especially if this suggestion gets implemented, as this functionality would be necessary for that suggestion to work correctly.

This would make it possible to block upgrades for XF itself, for instance we could specify that the version is compatible with XF >= 2.1.0 and < 2.2.0. The add-on would then need to be disabled before an upgrade to 2.2 could be performed.

In order to avoid having to rewrite the entire code that parses addon.json, I believe the simplest solution would be to add a "restrict": [] property that works in an inverse way to how "require": [] works.
 
Upvote 11
Top