Fixed  Mark forum read doesn't mark sub forums read?

SneakyDave

Well-known member
Don't know if this is really a bug or a feature, but if I'm in a forum with sub forums, and I mark the parent forum as "read" (using the "mark this forum read" link above and to the right of the list of threads) the sub-forum isn't marked as read. At least that what I assume is happening, when I visit the forum home again, I still see that the parent forum link is bold (unread), until I go into the sub forum, and mark that as "read".

Maybe its a feature? If it is, do you have to visit each sub forum and mark it read if you're not interested in it?

I tried a search, but couldn't find anything related to "mark forum read" and "sub forums".
 

Dean

Well-known member
How should subforums be handled when marking a forum read? It could get a little complicated, or maybe as simple as a 'subforums' radio button/check box.

?
 

Nick

Well-known member
I've actually always hated how marking a parent forum in vBulletin marks all of the sub-forums as read as well. What if I want to mark only the parent forum and its threads as read, but not the sub-forums? In vBulletin, I can't... but with XenForo's current setup, I can. :cool:

I like it how it is now.
 

Shamil

Well-known member
I've actually always hated how marking a parent forum in vBulletin marks all of the sub-forums as read as well. What if I want to mark only the parent forum and its threads as read, but not the sub-forums? In vBulletin, I can't... but with XenForo's current setup, I can. :cool:

I like it how it is now.
The link does say, "Mark all forums read"

But I still prefer double clicking the forum icon to mark it read.
 

Nick

Well-known member
The link does say, "Mark all forums read"

But I still prefer double clicking the forum icon to mark it read.
The subject of this thread as well as my post was the marking of forums with sub-forums as read. Not using the forum-wide "Mark all forums as read" button. ;)
 

Shamil

Well-known member
The subject of this thread as well as my post was the marking of forums with sub-forums as read. Not using the forum-wide "Mark all forums as read" button. ;)
How are you marking the forum read? I'm missing something.
 
Top