1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Manager forum: only selected users see forum on node tree?

Discussion in 'XenForo Questions and Support' started by Morgain, Jan 17, 2012.

  1. Morgain

    Morgain Well-Known Member

    I know I can set a forum to be Private, EXCEPT to a usergroup or selected users.
    But it seems to me I can only opt for it to be visible to all/ invisible to all on the node tree, with limited actual access.

    How can I make it appear in the node tree for 5 users, who use it for management, but invisible and inaccessible to everyone else?
  2. zaiger

    zaiger Active Member

    Go to acp > users > node permissions, set it to private. At the top right side of the screen (still in node permissions) there is a search box that says user name/set permissions. You can search for a user there and give them permissions to see/access the node.
    Morgain likes this.
  3. Morgain

    Morgain Well-Known Member

    Thank you Zaiger.
    Unfortunately I get an error on the Set Permissions part.

    The requested user could not be found.
    But I haven't got as far as putting in a username. This is when I click Set Permissions button.
    I better post this in troubleshooting.
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Click on the Node Permissions, select Private Node, click Update.

    Enter the user name in the field at the top, click Set Permissions.

    Select View Node: Allow, click Update Permissions.
  5. Morgain

    Morgain Well-Known Member

    Thank you Brogan. It's that pesky pale grey again - I can barely see it and not at all if I don't know it to be there.

    Do I set the main node editor to
    Display in the node list

    or not?

    I assume not but would like to be sure.
  6. Brogan

    Brogan XenForo Moderator Staff Member

    Yes, otherwise those who have access to it won't be able to see it.
    Morgain likes this.
  7. Morgain

    Morgain Well-Known Member

    Oh. I tested this by disabling the
    Display in node tree
    I thought the permission setting would be enough.
    But I couldn't see it even though I'm added to its users under the Set Permissions button.

    It might be clearer to make that text
    Display in the node list (subject to permissions given)

Share This Page