• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Mail Sending Problem with Google App

#1
Hello,

My forum can not sending mail with own domain (forum[at]gezenbilir[dt]com or iletisim[at]gezenbilir[dt]com)

When I changed forum email adress to gezenbilir[at]gmail[dt]com its working fine but the system does not send emails to the members whose email extensions are gezenbilir[dt]com. It sends emails to all the members except them (via gezenbilir[at]gmail[dt]com).

What is the problem you think?


Regards,


Code:
Zend_Mail_Transport_Exception: Email to kaan[at]gezenbilir[dt]com failed: Unable to send mail. - library/Zend/Mail/Transport/Sendmail.php:137
Oluşturan: Bilinmeyen Hesap, Salı 10:58
Yığın İzleme
#0 /home/gezenbilir/public_html/library/Zend/Mail/Transport/Abstract.php(348): Zend_Mail_Transport_Sendmail->_sendMail()
#1 /home/gezenbilir/public_html/library/Zend/Mail.php(1194): Zend_Mail_Transport_Abstract->send(Object(Zend_Mail))
#2 /home/gezenbilir/public_html/library/XenForo/Model/MailQueue.php(79): Zend_Mail->send(Object(Zend_Mail_Transport_Sendmail))
#3 /home/gezenbilir/public_html/library/XenForo/Deferred/MailQueue.php(10): XenForo_Model_MailQueue->runMailQueue(7.9999980926514)
#4 /home/gezenbilir/public_html/library/XenForo/Model/Deferred.php(295): XenForo_Deferred_MailQueue->execute(Array, Array, 7.9999980926514, '')
#5 /home/gezenbilir/public_html/library/XenForo/Model/Deferred.php(429): XenForo_Model_Deferred->runDeferred(Array, 7.9999980926514, '', false)
#6 /home/gezenbilir/public_html/library/XenForo/Model/Deferred.php(374): XenForo_Model_Deferred->_runInternal(Array, NULL, '', false)
#7 /home/gezenbilir/public_html/deferred.php(23): XenForo_Model_Deferred->run(false)
#8 {main}
Request State
array(3) {
  ["url"] => string(38) "http://www.gezenbilir.com/deferred.php"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(4) {
    ["_xfRequestUri"] => string(53) "/konu/check-engine-isigi-surekli-yaniyor.33146/page-4"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfToken"] => string(8) "********"
    ["_xfResponseType"] => string(4) "json"
  }
}
 

Mike

XenForo developer
Staff member
#2
This seems like a textbook mail server misconfiguration -- it's failing to handle your own domain. I couldn't really speak to the specifics of why, but there is likely more information in your mail server's log (possibly /var/log/maillog).
 
#3
This codes from log file?

Aug 22 02:45:40 gezenbilir sendmail[10774]: t7LNjeTm010774: to=iletisim@gezenbilir.com, ctladdr=gezenbilir+e5622d86+iletisim=gezenbilir.com@gmail.com (48/48), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=34851, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (t7LNjeBJ010775 Message accepted for delivery)
Aug 22 02:45:40 gezenbilir sendmail[10776]: t7LNjeBJ010775: to=<iletisim@gezenbilir.com>, delay=00:00:00, xdelay=00:00:00, mailer=local, pri=35223, dsn=2.0.0, stat=Sent
 
#5
Unfortunately no...
It looks like sent but mail was not received and also there is no any error in error log on ACP or /var/log/maillog.
This situation is only for the members whose email extensions are gezenbilir[dt]com. It sends emails to all other members.
 

Tracy Perry

Well-known member
#7
OK.. further investigation reveals you are using gmail apps for your email processing for gezenbilir.com (mxtoolbox.com to the front please).

Have you configured your MTA on the server to relay?
And I'm going to assume that you are NOT using gezenbilir.com for your server name (hopefully you did correctly and used a XXXX.gezenbilir.com format where XXXX is a name that makes for a FQDN).

One time I had that issue was when I had (when first setting up my very first server) my server name the same as my domain name.. and the domain mail was being processed by Google Apps.
I had to go from mydomain.com to (as an example) to chinchilla.mydomain.com as the server name (for a FQDN) and then configure the MTA (Postfix in my case) to forward all outbound email for the mydomain.com to Google for processing.
 

Tracy Perry

Well-known member
#9
Are you on shared hosting or are you on a VPS/dedi?
If VPS/Dedi, then no, the www is just a prefix. When you log into SSH it should show something similar to this
Code:
[tracy@whiskey ~]$
.
That's my username and the base subdomain for the server is whiskey.
The full domain is similar to whiskey.mydomain.com.

You CAN do it like you have it.. but you have to set up your MTA to recognize that no local mail is stored - it's all relayed. But it's generally easier to follow the normal FQDN practice of using a subdomain.basedomain.com
 
#10
Im using dedicated server and when I login the ssh I see that; [sedatt@gezenbilir ~]#
Does it mean my server name is gezenbilir.gezenbilir.com? And so is it ok?

Im waiting answer about MTA. Thank you friend.
 

Tracy Perry

Well-known member
#13
Like I said, you can configure it to work with that, but you HAVE to set up the MTA as a relay only and not have it store any mail locally. It's generally more hassle than it's worth to do that when it's simply changing the FQDN and then it will easily recognize that locally generated email to gezenbilir.com needs to go to your gmail app mx record.