Mail bug - mail not working.

LAPKBH

Member
The default mail have stopped working and have to use the smtp option and that is not working either. Just mail errors and nothing is working? What to do?

Error log from test mail:



++ Starting Swift_SmtpTransport
<< 220 mailout2.pub.mailoutpod1-cph3.one.com ESMTP


<< 250-mailout2.pub.mailoutpod1-cph3.one.com
250-PIPELINING
250-SIZE 104857600
250-AUTH LOGIN PLAIN
250-ENHANCEDSTATUSCODES
250 8BITMIME

> AUTH LOGIN

<< 334 VXNlcm5hbWU6

> aW5mb0BsYXAtbmV0LmRr

<< 334 UGFzc3dvcmQ6

> S3lsbGluZzE=

<< 235 2.7.0 Authentication successful

++ Swift_SmtpTransport started
> MAIL FROM:<***>

<< 550 5.7.1 Sender address rejected: Username info@lap-net.dk and sender *** doesn't match

!! Expected response code 250 but got code "550", with message "550 5.7.1 Sender address rejected: Username info@lap-net.dk and sender *** doesn't match
" (code: 550)
 

Sim

Well-known member
Sounds like you are trying to send email using an account on your hosting provider?

As an anti-spam measure, they are probably limiting which email address you use as the sender and insist that it matches the username that you authenticate with?

If so, you should start by contacting your hosting provider and ask them how to send email from a different user.

Alternatively, look at using a 3rd party email service provider to send emails - it will be far more reliable and flexible.
 
As an anti-spam measure, they are probably limiting which email address you use as the sender and insist that it matches the username that you authenticate with?
I think that's it. The error I'm getting is username and sender doesn't match.

I'm using the email I'm supposed to, and everything is setup correctly. I've had that confirmed.

Could you expand on where to set "user" and "sender", respectively, in Xenforo?

Alternatively, look at using a 3rd party email service provider to send emails - it will be far more reliable and flexible.
Yeah. I'm usually on AWS SES, but for some reason (prolly spam) they won't allow that. I think they block the ports.
 

Sim

Well-known member
Could you expand on where to set "user" and "sender", respectively, in Xenforo?

Assuming you are using SMTP - it will be as follows:

1582057541051.png

Yeah. I'm usually on AWS SES, but for some reason (prolly spam) they won't allow that. I think they block the ports.

Your host is blocking the ports?

They probably block port 25, but I believe you can also use port 587 or 2587 to connect to SES when using STARTTLS or port 465 or 2465 when using TLS? I don't use SES, so I'm not sure of the details - https://docs.aws.amazon.com/ses/latest/DeveloperGuide/smtp-connect.html
 
@Sim Thanks for trying.

Regarding the screenshot settings: I thought that was it, and that is already setup as it's supposed to be. Same email -- the email is an active one on the account, as instructed by One.com.

I've moved away from using AWS. They won't allow it, on account of "spam." Their support is clueless, so I've given up on finding out the exact reason why it won't work. Also, I've tried all those ports and more. None of them work.
 
So, I believe the following is the "specific" issue. For some reason the error tells me sender and user don't match, even though they do in my settings.

Same email in "sender" and "user" (admin@mysite.com), click Save and go and try "Test outbound email" - enter in foo@example.com to mail to, and click Run Test.

Code:
>> MAIL FROM:<admin+2ee3995f+foo=example.com@mysite.com>

<< 550 5.7.1 Username admin@mysite.com and sender admin+2ee3995f+foo=example.com@mysite.com doesn't match

!! Expected response code 250 but got code "550", with message "550 5.7.1 Username admin@mysite.com and sender admin+2ee3995f+foo=example.com@mysite.com doesn't match
" (code: 550)

I guess the question is, why does it inject the test target email into the "sender"?
 

Sim

Well-known member
That's sounding like your hosting provider doesn't have a very good SMTP implementation since they don't recognise "plus" addressing.

Try turning off the enableVerp setting in the email options.

1582139939862.png

That should stop the recipient being added to the sender address in the return path.

The Return-Path header in your emails is the important value here - this determines where bounced emails will go and is examined by anti-spam systems.
 
@Sim
Son of a mother... That did it! I wasn't aware of this setting, but it makes perfect sense now. Thanks Sim! I need to move away from that host, and get back onto AWS. But for now, this will do.
 
  • Like
Reactions: Sim
Top