1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Logo change after Installing New update?

Discussion in 'XenForo Questions and Support' started by MSiddiq, Feb 26, 2016.

  1. MSiddiq

    MSiddiq Member

    Its kind of annoying to change logo each time after new Xenforo update installation.
    Xenforo Development Team should Consider this issue.

    ** Another thing - FTP client takes longer time to upgrade Xenforo, during upgrading 'Forum' freeze with Xenforo default message. so is there any way to reduce time for upgrading ?

    Wordpress has auto update installation procedure from ACP as well it doesn't change the logo of the site after a new update. If possible Xenforo can add such options, so that it will be more user-friendly.

    Thank You.
  2. Brogan

    Brogan XenForo Moderator Staff Member

    You should change the Header Logo Image Path in the Style Properties to prevent that.

    If you have cPanel (or SSH), upload the zip archive and extract the files on the server.
    Alternatively, FTP the files to a temporary directory, then move them once they are all uploaded.
    melbo likes this.
  3. Tracy Perry

    Tracy Perry Well-Known Member

    Actually.. what you SHOULD do is create a child style of whatever one you are using (it appears to be the default), THEN change the Header Logo Image Path and also create a new directory in the styles folder for your images - copy the original /styles/default files over to the new directory you created and change

    Screen Shot 2016-02-26 at 7.09.04 PM.png
    to point at the new location.

    That way, any template edits, etc. you do will be on it's own style and not the default. Reduces any impact that changes (file/images) the default has to your style.
    melbo likes this.
  4. dieketzer

    dieketzer Well-Known Member

    while all the above is true, i still see no good reason to include something like the logo in every update.
    melbo likes this.
  5. melbo

    melbo Well-Known Member

    I don't encounter this problem but agree that an upgrade package shouldn't include images that haven't changed.
    Mr Lucky likes this.

Share This Page