1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Login slider no longer works

Discussion in 'Troubleshooting and Problems' started by WhoIsDo, Aug 18, 2013.

  1. WhoIsDo

    WhoIsDo Active Member

    Since upgrading to 1.2, my login slider (where users click "login" in the upper-right) no longer works. The "Search" function in the admin panel is no longer able to be clicked either. Any idea what's happening?
     
  2. Mike

    Mike XenForo Developer Staff Member

    Do you have a URL example?

    In general, I'd recommend confirming on a default style and also using the file health check to confirm the files have been uploaded correctly.
     
  3. WhoIsDo

    WhoIsDo Active Member

    Hi Mike,

    Here's the URL. The login slider is pretty temperamental at this point, as it'll work some times but not at others. I've checked the file health and everything checked out fine.
     
  4. Jeremy

    Jeremy XenForo Moderator Staff Member

  5. WhoIsDo

    WhoIsDo Active Member

    Thanks, I'll try that. It started "working" again before I removed that piece of code, but I'll keep tabs on it to see if it happens again.
     
  6. WhoIsDo

    WhoIsDo Active Member

    Tried the solution suggested in that thread, but it didn't actually seem to stick. I've noticed that when the search doesn't work in the admin panel, the little magnifying glass isn't present. Any ideas?
     
  7. RoldanLT

    RoldanLT Well-Known Member

    Disable "Rocket Loader" on your website at CloudFlare settings.
     
  8. RoldanLT

    RoldanLT Well-Known Member

  9. WhoIsDo

    WhoIsDo Active Member

    Even if I disabled & removed Cloudflare? I don't even have that website listed on Cloudflare, so would that feature still be affecting it?
     
  10. Mike

    Mike XenForo Developer Staff Member

    You can see the CloudFlare and Rocketscript changes still happening:
    Code:
    <script type="text/javascript">
    //<![CDATA[
    try{if (!window.CloudFlare) { var CloudFlare=[{verbose:0,p:0,byc:0,owlid:"cf",mirage:{responsive:0,lazy:0},mirage2:0,oracle:0,paths:{cloudflare:"/cdn-cgi/nexp/abv=1772709731/"},atok:"9672721e2d2c4dfa9496cb8a83e284b1",zone:"playst4tion.com",rocket:"a",apps:{}}];document.write('<script type="text/javascript" src="//ajax.cloudflare.com/cdn-cgi/nexp/abv=2310247235/cloudflare.min.js"><'+'\/script>')}}catch(e){};
    //]]>
    </script>
    <script type="text/rocketscript">
    var _b = document.getElementsByTagName('base')[0], _bH = "http://www.playst4tion.com/community/";
    if (_b && _b.href != _bH) _b.href = _bH;
    </script>
    
    Code:
    <script data-rocketsrc="js/jquery/jquery-1.10.1.min.js" type="text/rocketscript"></script>
    <script data-rocketsrc="js/xenforo/xenforo.js?_v=0c16152a" type="text/rocketscript"></script>
    
     
  11. WhoIsDo

    WhoIsDo Active Member

    Should I go back & set up Cloudflare, only to disable Rocketscript, pause & then delete it? Not sure what to do since I have it removed. I may have installed it via my host, but there's nothing on Cloudflare's website...
     
  12. RoldanLT

    RoldanLT Well-Known Member

    Go to Cpanel > CloudFlare > Disable your site on CLoudFlare.
     
  13. WhoIsDo

    WhoIsDo Active Member

    Oddly enough, that function didn't work until you posted for me to do that. I've disabled it from cPanel. The code is gone now, correct?
     
  14. RoldanLT

    RoldanLT Well-Known Member

    Yes, looks fine now.
    The only reason on your problem is rocket loader.
     
    WhoIsDo likes this.
  15. WhoIsDo

    WhoIsDo Active Member

    Thanks for your help!
     
    RoldanLT likes this.
  16. Tracy Perry

    Tracy Perry Well-Known Member

    They need to rename it to Rocket Xploder Loader since it blows up a lot of stuff. Of course, that is why (last I looked) it was shown as BETA.
     
    WhoIsDo likes this.

Share This Page