1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Login Problem / Blank Page / Error Page

Discussion in 'Troubleshooting and Problems' started by yes, Jun 27, 2014.

  1. yes

    yes Member


    I have just installed my XF 1.3.3 for the first time and the installation seems to have gone ok. I can see the homepage forum fine and I can access the admin panel ok. However, my issue is in reference to logging in on the homepage. When I try to do so, I see the login screen, but after I enter my information I receive 404 errors or blank pages on all the links I click on (members online, inbox, conversations, search...anything at all).

    Can anyone help sort me out as I am a bit baffled as to what's going on.

    FWIW, I have my htaccess file on. I have use friendly urls enabled. I have jquery being served from Google. Cloudflare is also on for the domain as well.

    The board is using MySQL 5.5 and PHP 5.4.28 as well if that would trigger anything. The error that appears is 404 not found / nginx or a blank page, see examples below:

    Here is an example on my site of the 404 Error: http://jvnk.com/members/
    Here is an example of the blank page that shows: http://jvnk.com/find-new/posts

    Here is also currently what my htaccess looks like:
    # disable directory browsing
    Options All -Indexes

    AllowOverride All
    Order allow,deny
    Allow from all

    # Protect htaccess
    <files ~ "^.*\.([Hh][Tt][Aa])">
    order allow,deny
    deny from all
    satisfy all

    Options +FollowSymLinks

    RewriteCond %{HTTP_HOST} !^www.jvnk.com$ [NC]
    RewriteRule ^ http://jvnk.com/? [R=301]

    # Mod_security can interfere with uploading of content such as attachments. If you
    # cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    # SecFilterEngine Off
    # SecFilterScanPOST Off

    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default

    <IfModule mod_rewrite.c>
    RewriteEngine On

    # If you are having problems with the rewrite rules, remove the "#" from the
    # line that begins "RewriteBase" below. You will also have to change the path
    # of the rewrite to reflect the path to your XenForo installation.
    #RewriteBase /xenforo

    # This line may be needed to enable WebDAV editing with PHP as a CGI.
    #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]


    Thanks in advance for any assistance.

    Last edited: Jun 27, 2014
  2. Brogan

    Brogan XenForo Moderator Staff Member

  3. yes

    yes Member

    I haven't done that yet. I will look into doing that now.

    I have a question about doing this, when it says make the change in your 'server configuration', what and where exactly is this that I'd implement the nginx friendly url text?

    Also, my forum sits at jvnk.com and not in a folder, so when it mentions to change the path of 'location /xf/ ' to my own, what would that look like/be? 'loclation /' ???

    Also, on a separate note, my config file under /library/ is config.php.default, does this need to be changed to config.php only? In addition, the contents on the inside of this file only is:


    $config['db']['host'] = 'localhost';
    $config['db']['port'] = '3306';
    $config['db']['username'] = '';
    $config['db']['password'] = '';
    $config['db']['dbname'] = '';

    $config['superAdmins'] = '1';

    Is that correct? I entered my details in it earlier, but they've since gone away.

    And finally with that said, I've changed all permissions in the data and internal data folders, but do the rest of my folders permissions look correct or do I need to adjust them accordingly?


    Last edited: Jun 27, 2014
  4. Brogan

    Brogan XenForo Moderator Staff Member

    I don't use nginx but I presume it's the nginx.conf file.

    If your install is in the web root then you don't need the /xf or equivalent, but it may need to be the true or absolute path.

    Your config.php file is in place and working, otherwise your site wouldn't load at all.

    Yes, the files and directories look fine.
  5. Tracy Perry

    Tracy Perry Well-Known Member

    The nginx configuration is set for your vhost (depends on whether you are running centOS with CentMin Mod or Debian with default install on where it will be).
    Each domain will have it's own vhost.
    Setting nginx up is much more complicated (if you are not used to it) than Apache or LiteSpeed/OpenLiteSpeed.
  6. kingofseo

    kingofseo New Member

    Can you set Phphandler as apache module please.
  7. yes

    yes Member

    I think perhaps turning off nginx might be the easiest option? At the same time, I don't want to quit because it is difficult getting setup, but at the same time if it is 'overkill', then would it be too much hassle. If setting things up for it now will benefit the long run, I don't mind leaving it enabled. Any feedback / insight is appreciated as I'm not sure of the need v. non-need

    @Tracy Perry - I'm running cent0S 6.2 on an Amazon EC2

    @kingofseo - I've switched the phphandler from FastCGI to Apache Module. Is it best to use the Apache Module over FastCGI as I am not familiar with the differences. I'm assuming the other settings look ok as well?

    Also, in my server settings, it gives me the following options for nginx, currently all are enabled - would this be correct?

    Also, in the 'Additional nginx directives' box, could I put the nginx friendly url information in that box or would it not be for it at all?

    Thanks for the help,

    Last edited: Jun 27, 2014

Share This Page