Fixed LogicException: Column 'title' is required and has an empty value while importing

vplusasia

Member
Hello,
I am trying to import from contents from one xenforo 2.2.1 forum to another board ( xenforo 2.2.1) and I got this error.
Is there any ways to fix it?

erro-import.png

LogicException: Column 'title' is required and has an empty value while importing XF:Warning with id = 1 in src/XF/Import/Data/EntityEmulator.php at line 282
  1. XF\Import\Data\EntityEmulator->getWriteData() in src/XF/Import/Data/EntityEmulator.php at line 326
  2. XF\Import\Data\EntityEmulator->insert() in src/XF/Import/Data/AbstractEmulatedData.php at line 71
  3. XF\Import\Data\AbstractEmulatedData->write() in src/XF/Import/Data/AbstractData.php at line 127
  4. XF\Import\Data\AbstractData->save() in src/addons/XFI/Import/Importer/XenForo2.php at line 2071
  5. XFI\Import\Importer\XenForo2->stepWarnings() in src/XF/Import/Runner.php at line 242
  6. XF\Import\Runner->runStep() in src/XF/Import/Runner.php at line 59
  7. XF\Import\Runner->run() in src/XF/Admin/Controller/Import.php at line 234
  8. XF\Admin\Controller\Import->actionRun() in src/XF/Mvc/Dispatcher.php at line 350
  9. XF\Mvc\Dispatcher->dispatchClass() in src/XF/Mvc/Dispatcher.php at line 257
  10. XF\Mvc\Dispatcher->dispatchFromMatch() in src/XF/Mvc/Dispatcher.php at line 113
  11. XF\Mvc\Dispatcher->dispatchLoop() in src/XF/Mvc/Dispatcher.php at line 55
  12. XF\Mvc\Dispatcher->run() in src/XF/App.php at line 2300
  13. XF\App->run() in src/XF.php at line 465
  14. XF::runApp() in admin.php at line 13



Thanks in advance.
 

Ozzy47

Well-known member
I would just try saving. Then try the import again. I’m not 100% sure if that will help, but it’s a start.
 

Mike

XenForo developer
Staff member
Just to clarify, this error relates to a specific warning that a user has received, not a warning definition (what you see in the control panel).

Regarding the source forum, did you import into XenForo in the past? If so, what software did you import from?

If you didn't import, then this would be invalid data that XF would normally not allow you to create, so I'm not totally sure how it happened. You may need to manually add a title to this warning directly in the database.
 

vplusasia

Member
Just to clarify, this error relates to a specific warning that a user has received, not a warning definition (what you see in the control panel).

Regarding the source forum, did you import into XenForo in the past? If so, what software did you import from?

If you didn't import, then this would be invalid data that XF would normally not allow you to create, so I'm not totally sure how it happened. You may need to manually add a title to this warning directly in the database.

Thank you for your reply.
In the part, I imported content from vbulletin (4) in to xenforo for my source forum.

Should I still manually add a title to this warning directly in the database? If yes, Could you please tell me how to do it?
Or should I do some other things to fix this?
 

Brogan

XenForo moderator
Staff member
If you have phpMyAdmin, click on the xf_warning table.

Then click on the title column to sort and the entry which is blank should be at the top.

Then you can click edit and add a title, and save.
 

XF Bug Bot

XenForo bug fixer bot
Staff member
Thank you for reporting this issue, it has now been resolved. We are aiming to include any changes that have been made in a future XFI release (1.4.1).

Change log:
When importing warnings, ensure we never import a warning with an empty title.
There may be a delay before changes are rolled out to the XenForo Community.
 
Top