1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Logged In Issue

Discussion in 'Installation, Upgrade, and Import Support' started by MajesticMonkey, Jul 27, 2013.

  1. So for the first time in my life I created a hidden development site (something I have never done before but something I thought was important now considering the direction xF is moving in).

    I uploaded xF 1.2 installed it, created my admin account etc however now whenever we go to do ANYTHING it always logs us out. We click 'Stay Logged In' go to the next page and we are logged out.

    I know that this isn't supported however wanted to report it because:-
    1) It is very annoying :D
    2) Its my first development site and I want to see xF improve with each release.
    3) I want to work on my sites style and addons etc with each release that comes out and so when xF 1.2 is actually released we are able to update ASAP following it with our updated style/addons.

    If anyone has any suggestions or ideas on how to fix it it would be greatly appreciated. I have tried editing the htaccess however don't think I am doing it right considering that we are on website.com/development but I am new to using htaccess for anything and so don't know if my coding is right.

    If anyone is able to help, or provide some suggestions on how I could possibly fix it it would be greatly appreciated.
  2. xf_phantom

    xf_phantom Well-Known Member

    have you set a cookie prefix, cookie domain and cookie path in your config.php ?
  3. I don't see any of that in the config I will go and look again - thanks for the suggestion I truly appreciate it.
  4. Mike

    Mike XenForo Developer Staff Member

    Or set up any caching in your config.php?
  5. Brogan

    Brogan XenForo Moderator Staff Member

    I would recommend adding this to /library/config.php:
    $config['enableMail'] = false;

    $config['cookie'] = array(
    'prefix' => 'dev_',
    'path' => '/',
    'domain' => ''

    $config['debug'] = true;
    That will set a different cookie domain to your live site, disable email sending and configure debug mode.
    xf_phantom likes this.
  6. Thank you guys so much - I truly appreciate all the support was driving me insane.
    That seems to be working for now but will see if it stays this way :D

Share This Page