LiteSpeed + Redis issues

#1
Hello, I upgraded to LiteSpeed last night and then decided to get Redis up and running on our site (the-mainboard.com). LiteSpeed improved the "feel" of the site and the speed, as did switching to PHP7, but when I installed Redis and the Xon plugin it actually slowed down the site quite a bit for some reason. I disabled it for now, but I was wondering if there was anything that could cause this? I'm on XF 1.5, and still using MySQL for database at the moment. These are the cache settings I used:

Code:
$config['cache']['enabled'] = true;
$config['cache']['cacheSessions'] = true;
$config['cache']['frontend'] = 'Core';
$config['cache']['frontendOptions'] = array(
'caching' => true,
'cache_id_prefix' => 'xf_',
'automatic_serialization' => false,
'lifetime' => 0
);

$config['cache']['backend'] = 'Redis';
$config['cache']['backendOptions'] = array(
'server' => '127.0.0.1',
'port' => 6379,
'connect_retries' => 2,
'use_lua' => true,
);
require(XenForo_Application::getInstance()->getConfigDir().'/SV/RedisCache/Installer.php');
Any ideas?
 
#6
You installed Redis and it's php module?
Redis Version: 3.2.5
phpredis version: 3.0.0
I did, we run a dedicated server so I installed Redis through my CentOS command line and the php extension through our WHM install.

I used Redis settings I found on here, I don't have them handy at the moment but I remember the maxmemory was set at 100mb.
 

Xon

Well-known member
#8
Can you try adding the following towards the end of your config.php
Code:
$config['cache']['backendOptions']['force_standalone'] = false;
It may be a compatibility issue with phpredis and how Litespeed hosts php

:edit: fix typo.
 
Last edited:

Xon

Well-known member
#10
That immediately crashes the site.
Oops, typo sorry.

It should be this:
Code:
$config['cache']['backendOptions'] = array(
'server' => '127.0.0.1',
'port' => 6379,
'connect_retries' => 2,
'use_lua' => true,
'force_standalone' => false,
);
or
Code:
$config['cache']['backend'] = 'Redis';
$config['cache']['backendOptions'] = array(
'server' => '127.0.0.1',
'port' => 6379,
'connect_retries' => 2,
'use_lua' => true,
);
$config['cache']['backendOptions']['force_standalone'] = false;
 
Top