1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed List of Installed Add-ons not clickable anymore.

Discussion in 'Resolved Bug Reports' started by Vincent, Jun 5, 2011.

  1. Vincent

    Vincent Well-Known Member

    At the admin home page, there is a list with addons and you can click on them and then you can edit some stuff like version id etc.

    Now, in the addon list (the seperate page) you cannot access version id etc.
    You can only uninstall, disable and upgrade.

    I see this as a bug. Correct me if I'm wrong..
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    This is by design so it's not a bug as such.

    It could be a suggestion though.
     
  3. Mike

    Mike XenForo Developer Staff Member

    Well, it should be consistent. I believe they're only clickable in debug mode, but that should possibly change.
     
  4. ragtek

    ragtek Guest

    Exactly. They're only clickable in debugmode (to be able to change url, version, etc..) BUT IMHO Avarage joe shouldn't be able to edit the version id,addon id, etc...
    So, IMHO they shouldn't be clickable ANYWHERE without debugmode (or open only the menu with upgrade,deactivate/..) as requested => here
    http://xenforo.com/community/threads/add-add-on-upgradelink-on-acp-index-page.15629/
     
    Steve F likes this.
  5. Vincent

    Vincent Well-Known Member

    I've thought of both ways as a bug but have reported the wrong one :p

    Anyhow, something has to be fixed :p
     
  6. Mike

    Mike XenForo Developer Staff Member

    The link on the ACP index is now only for debug mode (ie, the add-ons list page was correct).
     
    Vincent likes this.
  7. Vincent

    Vincent Well-Known Member

    May I recommend linking the text to the link set by the developer of the addon?
    If not in debug mode

    It makes it easier to check for updates
     
    Darkimmortal likes this.

Share This Page