1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Link causes thread to error...

Discussion in 'Troubleshooting and Problems' started by Paul, Dec 10, 2013.

  1. Paul

    Paul Well-Known Member

    Hiya,

    Ok so a user of mine tried to put a link in a conversation on my board, however it failed.... also t fails if inserted in a thread....

    Link : http://pinside.com/pinball/forum/topic/metallica-rules-how-to-play-pro-v-106-rulesheet

    Error :
    Code:
    Error Info
    Zend_Db_Statement_Mysqli_Exception: Mysqli statement execute error : Incorrect string value: '\xAB Pins...' for column 'message' at row 1 - library/Zend/Db/Statement/Mysqli.php:214
    
    Stack Trace
    #0 **********/public_html/community/library/Zend/Db/Statement.php(297): Zend_Db_Statement_Mysqli->_execute(Array)
    #1 **********/public_html/community/library/Zend/Db/Adapter/Abstract.php(479): Zend_Db_Statement->execute(Array)
    #2 **********/public_html/community/library/Zend/Db/Adapter/Abstract.php(574): Zend_Db_Adapter_Abstract->query('INSERT INTO `xf...', Array)
    #3 **********/public_html/community/library/XenForo/DataWriter.php(1612): Zend_Db_Adapter_Abstract->insert('xf_post', Array)
    #4 **********/public_html/community/library/XenForo/DataWriter.php(1601): XenForo_DataWriter->_insert()
    #5 **********/public_html/community/library/XenForo/DataWriter.php(1393): XenForo_DataWriter->_save()
    #6 **********/public_html/community/library/MetaMirror/DataWriter/DiscussionMessage/Post.php(24): XenForo_DataWriter->save()
    #7 **********/public_html/community/library/XenForo/ControllerPublic/Thread.php(548): MetaMirror_DataWriter_DiscussionMessage_Post->save()
    #8 **********/public_html/community/library/XenForo/FrontController.php(337): XenForo_ControllerPublic_Thread->actionAddReply()
    #9 **********/public_html/community/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #10 **********/public_html/community/index.php(13): XenForo_FrontController->run()
    #11 {main}
    Request State
    array(3) {
    ["url"] => string(90) "http://**********/community/threads/replying-to-conversation-error.7789/add-reply"
    ["_GET"] => array(0) {
    }
    ["_POST"] => array(9) {
    ["message_html"] => string(198) "<p><a href="http://pinside.com/pinball/forum/topic/metallica-rules-how-to-play-pro-v-106-rulesheet">http://pinside.com/pinball/forum/topic/metallica-rules-how-to-play-pro-v-106-rulesheet</a><br></p>"
    ["_xfRelativeResolver"] => string(81) "http://**********/community/threads/replying-to-conversation-error.7789/"
    ["attachment_hash"] => string(32) "71202a0e05a80296b6c447d297e91ffb"
    ["last_date"] => string(10) "1386683665"
    ["last_known_date"] => string(10) "1386683665"
    ["_xfToken"] => string(8) "********"
    ["_xfRequestUri"] => string(55) "/community/threads/replying-to-conversation-error.7789/"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfResponseType"] => string(4) "json"
    }
    }
    
    
    Has anyone any clues as to where the problem might lie??

    Many thanks
    Paul
     
  2. Jeremy

    Jeremy XenForo Moderator Staff Member

    If you add the link and disable MetaMirror, does it still error out?
     
  3. Paul

    Paul Well-Known Member

    Ahh i see what you have done there..... I missed it on reading through the error....

    Will check and get back in a couple... Many thanks Jeremy....
     
  4. Paul

    Paul Well-Known Member

    Interesting.... Have disabled Metamirror, however still get the error, and still get the mention to Metamirror... I'll ping the author and see if he can assist, since it's possibly looking that way...

    Cheers
    Paul
     
  5. Jeremy

    Jeremy XenForo Moderator Staff Member

    How did you disable MetaMirror?
     
  6. Paul

    Paul Well-Known Member

    Options -> Metamirror and then unticked "Enable MetaMirror Image Rehosting" and "Instant Reshosting"... Then saved and re-posted.... o_O
     
  7. Mike

    Mike XenForo Developer Staff Member

    It's caused by an add-on that changes links to their page titles.
     
  8. xf_phantom

    xf_phantom Well-Known Member

    You'll need to disable the addon;)
     
  9. Brogan

    Brogan XenForo Moderator Staff Member

    I think that's @Chris Deeming's add-on, which has already been reported and he has acknowledged.
     
  10. Paul

    Paul Well-Known Member

    Which is that Paul???
     
  11. Brogan

    Brogan XenForo Moderator Staff Member

  12. Paul

    Paul Well-Known Member

    Mike - Dont quite get what you mean... you're saying it's an issue with the link itself and where it points to??

    DOH!!! - It's been a long day already, and it's only 16:30.....:LOL:
     
  13. Paul

    Paul Well-Known Member

  14. Jeremy

    Jeremy XenForo Moderator Staff Member

    Although its been solved, I'd like to point out when its mentioned to "Disable an add-on", we mean going into the add-ons and actually disabling the add-on from the add-on list (it is a checkbox) and not any internal options of the add-on. Alternatively, you can add the configuration option to globally disable listeners.
     
    Paul likes this.

Share This Page