1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Browser Issue Latest/first unread post in a thread positioning bug

Discussion in 'Resolved Bug Reports' started by Martok, Jun 6, 2013.

  1. Martok

    Martok Well-Known Member

    When clicking on a thread to read the last post or the first unread post, the page should open with the last/first unread post in view with the top of that post positioned at the top of the screen.

    On my Nexus 7 using Chrome, this responds correctly if the thread is opened in the same window. However, if it's opened in a new tab (which I do a lot as I go through the new threads list and open all of the ones I want to read) the page position is incorrect - it's positioned so that the very bottom of the page is at the bottom of the window. I've tested this in both portrait and landscape view and get the same results.

    This bug has only occurred in 1.2, all was fine in 1.15.
     
  2. Mike

    Mike XenForo Developer Staff Member

    I reproduced this once (on my phone running Chrome) but then every other time it was correct. I'm not sure how we could affect this at all between opening in a new tab vs inline. In general, they both load pages that then redirect to a page with a hash that the scroll is set by.

    Can anyone else reproduce this consistently?
     
  3. Martok

    Martok Well-Known Member

    I've just tested it on my partner's Nexus 7 and replicated the issue.

    I think I can be more specific on how you can replicate this more consistently.

    1. Choose a thread that you have previously read that has new posts in it
    2. Click on the title of the thread and choose to open it in a new tab
    3. Remain on the current tab until the new page has fully loaded in the new tab
    4. Switch to the new tab. The page will display such that the very bottom of the page is at the bottom of the window.

    This can also be replicated with thread with no new posts in them:
    1. Choose a thread that has no new posts in it
    2. Click on the dats under the time/date in the Last Message column and choose to open it in a new tab
    3. Remain on the current tab until the new page has fully loaded in the new tab
    4. Switch to the new tab. The page will display such that the very bottom of the page is at the bottom of the window.

    Now I tested these steps again but instead of waiting until the new tab had fully loaded, I switched to the new tab as it was still loading. When I did this, each time the page position was correct with the last/first unread post in view with the top of that post positioned at the top of the screen. So it appears that it's also related to the focus of a tab - when not in focus, it'll display the issue but when it is, it loads correctly.


    It all seems very strange behaviour and I've no idea why opening in a tab and letting the page load when the tab is not in focus should affect the page positioning compared to opening it in other ways.
     
  4. Mike

    Mike XenForo Developer Staff Member

    Unfortunately I really don't think we can do anything about this. It may be doing something like laying it out with the wrong width and then reflowing it when the tab is opened but keeping the same scroll position. Simply enabling the viewport changes for responsive could be enough to trigger this.
     
  5. Martok

    Martok Well-Known Member

    I thought I'd post an update to say that this issue seems to be resolved.

    I'm not sure if anything has changed in the latest beta or if the latest version of Chrome on Android has sorted this. Anyway, the latest/first post is now in the correct position when a thread is opened in a background tab. :)
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

    There was an Android Chrome update pushed out this week.

    Hopefully a lot of these annoying browser bugs are now resolved.
     

Share This Page